Forum: Ruby on Rails No joy for newbie Capistrano user

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Douglass T. (Guest)
on 2006-05-25 23:00
(Received via mailing list)

I tried taking Capistrano out for a test drive and I can't even get out
the garage.

I am following the instructions here:

As well as Duncan Davidson's Deploying Rails with Lighty:
Deploying Rails with

Specifically, when I do:

rake remote:exec ACTION=setup

I get this error:

    loading configuration
    loading configuration ./config/deploy.rb
  * executing task setup
  * executing "mkdir -p -m 775 /usr/www/rails/hellorails/releases
/usr/www/rails/hellorails/shared/system &&\n    mkdir -p -m 777
    servers: [""]
(in /home/turner/play/rails/hellorails)
rake aborted!
no such file to load -- openssl

Can someone please lend a hand. Thanks alot!
Doug Turner
mobile: 781 775 3708
skype: dduuggllaa
Ray B. (Guest)
on 2006-05-25 23:51
(Received via mailing list)
Douglass T. wrote:

> I tried taking Capistrano out for a test drive and I can't even get out
> of the garage.

I'd say you were out of the garage, but still in the driveway.

> no such file to load -- openssl

You need to install openssl ruby bindings on your server. I'm not an
expert on this, but I believe that many (most?) Ruby installs include
these, but it may not be installed by default on some systems including
Debian and derivatives.

Consult the documentation for your server.


Douglass T. (Guest)
on 2006-05-26 00:00
(Received via mailing list)
I'm on a SuSE box. What is the name of the module I need to gem install?

Douglass T. (Guest)
on 2006-05-26 00:51
(Received via mailing list)
Can someone please explain to me how to install a newer version of the
openssl/openssh libraries on my find old SuSE 8.2 box. I can't use RPM,
does not install a version high enough to prevent rake from aborting
running: rake remote:exec ACTION=setup. The relevant ruby script
openssl > 0.9.6. SuSE 8.2 RPM only goes up to 0.9.6i. I need 0.9.7 or

I can't just uninstall the RPM due to dependency hell.

I'm completely stumped.

This topic is locked and can not be replied to.