Forum: Ruby on Rails require: "No such file to load"

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Simon D. (Guest)
on 2006-05-16 20:40
(Received via mailing list)
Hi,

I'm having trouble with Rails failing to find things I've installed
with Rubygems... (I'm new to rails so I might not be doing this
correctly.)

First I tried to use 'calibre/bbcode'. My 'gem install calibre-bbcode'
worked, and I can use it from within irb with no problems... But when
I tried to "require 'calibre/bbcode'" from a Rails app, it says "No
such file to load"

I figured this was a bug in calibre-bbcode. So I ignored it and went
on to something else. Later on in the day I tried to use 'diff-lcs'.
Again 'gem install diff-lcs' works, and I can use it from within IRB.
But when I try to require it from a Rails app, it again says "No such
file to load".

How can I make this problem go away?

Thanks,
Simon

--
Simon Detheridge
SEN Developer, Widgit Software






This message has been scanned for viruses by BlackSpider MailControl -
www.blackspider.com
This topic is locked and can not be replied to.