Forum: rforum installation at Site 5.

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Bryan W. (Guest)
on 2006-05-16 16:05
I followed the readme instructions, and I changed the paths is
dispatch.fcgi and dispatch.rb to show Ruby in #!/usr/bin/ruby

My site still is not resolving.

So, it seems that the .htaccess file is rewriting the root to show:

There is a controller called forum, so I don't understand why it would
not be showing up.
I validated that this .htaccess file was changing the root url by
putting in different root controller names.

It may have something to do with the fact that there are not any
forums or posts to display.

The installation readme suggested that I need to create a new user by
navigating to:

However, this gives me:
The error was: "lost network connection"

So, I'm not sure what's going on.

Bryan W. (Guest)
on 2006-05-16 19:48
The application is crashing on startup causing the errors that you're

Are there any additional gems that rForum requires?
Bryan W. (Guest)
on 2006-05-17 18:15
I'm wonder if it's just not possible to install Rforum at

I deleted the un--needed files lang files.

I changed the paths is dispatch.fcgi and dispatch.rb to show Ruby in

I'm still getting the same errors..
â??lost network connectionâ? (NSURLErrorDomain:-1005)

How did you find the error you posted above?
I'm not seeing any errors in the apache error log

My app log files ( /home/spiritua/rforum/trunk/log ) are not being
updated either, so I can't use that to diagnose the problem.

I tried to change
.htaccess now to point to dispatch.cgi

I got an Application Error @ root

This could be because there are no users or posts.
When I go to:

The same error.
If this were really an application error, wouldn't it be logging the
errors in

Any idea what this error is?
[Tue May 16 15:44:23 2006] [error] [client] Premature end
of script headers: /home/spiritua/public_html/dispatch.cgi
Dinshaw G. (Guest)
on 2006-11-14 06:23
Bryan W. wrote:
> I'm wonder if it's just not possible to install Rforum at
it is. I have it close...

The Ferret plugin is tricky. 0.9.6 is the only one that seems to let the
app load.
Everything is great except that I had to add a route to make it not
throw a "Forum not found" error with just the domainn inn the address

but now.... I get this garbage when i try to post a new tpic when
loggged in as admin. I found another post here:
that said i needed to upgrade Ferret. But i can;t cause then rForum.

I am starting to think that rForum is not ready for release at all.

Has anyone noticed that if you put any special charicters in the search
box it throws an error (without even a 505 page)?

Also it does not seem to run with edge rails but i di not fool around
with that tpp much.
An help would be appriciated regardinng the below error

NoMethodError (undefined method `exists?' for {:term_vector=>:no,
:index=>:yes, :store=>:no, :boost=>1.0}:Hash):
    /app/models/forum.rb:41:in `add_post'
    /app/models/forum.rb:36:in `add_post'
    /app/controllers/topic_controller.rb:97:in `new'
    /usr/lib/ruby/1.8/benchmark.rb:293:in `measure'
Dinshaw G. (Guest)
on 2006-11-14 06:53
Dinshaw G. wrote:
in response to my self.. it see,s the prooblem is Site5, not rForum..
Works perfect on my mac.
This topic is locked and can not be replied to.