Forum: Ruby on Rails Rails freeze, weird error

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Josh on Rails (Guest)
on 2006-05-10 00:29
(Received via mailing list)
Hello --

So, I have a bunch of apps on my dev box, all currently v1.0.0. I
thought I
could use the freezing techniques to test each app for 1.1.x
individually, but that doesn't seem to be working out...

First, I checked out from into vendor/rails

Then I ran "rake rails:update".

Then I went into console, and tried to check the current version of

$ rake rails:update
$ ruby script/console
Loading development environment.
/usr/lib/ruby/1.8/test/unit/assertions.rb:265: warning: already
initialized constant UncaughtThrow
`const_missing':NameError: uninitialized constant
=> "1.0.0"
>> Loaded suite irb

Finished in 0.0 seconds.

0 tests, 0 assertions, 0 failures, 0 errors
/usr/lib/ruby/1.8/irb.rb:76:in `throw': uncaught throw `IRB_EXIT'
        from /usr/lib/ruby/1.8/irb.rb:76:in `irb_exit'
        from /usr/lib/ruby/1.8/irb/context.rb:226:in `exit'
        from /usr/lib/ruby/1.8/irb/extend-command.rb:24:in `exit'
        from /usr/lib/ruby/1.8/test/unit.rb:285
        from /usr/bin/irb:13

I'm guessing, for now, that I can't do what I wanted to do (Rails 1.1.x
vendor/rails externals) but I'm not sure why. And, does this mean that
be unable to jump to Rails 1.1.x until my shared host goes _at least_
far? (In other words, this freezing business appears to only work going
backwards, not forwards.)
Josh on Rails (Guest)
on 2006-05-10 00:35
(Received via mailing list)
Ah, well... A little extra Googling tells me the problem is actually
using the Engines plugin.

Removing the "Engines.start" line didn't fix this, however; I had to
engines from my plugins directory to make it go away.
This topic is locked and can not be replied to.