Forum: Ruby on Rails plural names such as countries

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
SIX-S (Guest)
on 2006-05-09 09:54
(Received via mailing list)
I found out that Rad Rails names could be properly made plural, such as
"country" = "countries" not "countrys".
I have a database that contained one table  named "countrys". I
pluralized the name by adding an "s" as "countrys".I ran the Rad Rails
generator and created a "controller"  that was named "country index".
Rad Rails  made the plural of "country" as "countries" and I got an
error message. I went to mysql database and changed the name of the
table to "countries" and then ran the generator again. I got an error,
so I ran the generator marked as "destroy". I then ran the generator
marked as "create"

I wondered what problem this caused me. Did I do enough by just running
generator with "destroy"  or is there more to do?
Thanks for any help!
This topic is locked and can not be replied to.