Forum: Ruby win32ole and activex

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Johan Duflost (Guest)
on 2006-05-05 12:10
(Received via mailing list)
Hello all,

I tried to use win32ole standardlib with an activex control but I got
'Library not registered' error message.
Here is the code :

require 'win32ole'
sf ='MapWinGIS.Shapefile')

method_missing': Unknown property or method `Open'
HRESULT error code:0x8002801d
Library not registered

The open method is present in the specs and the library is registered so
I don't understand.

I'm not familiar with windows programming so the way I use to connect to
the activex with ruby is perhaps not the good one.

Does anybody know where the problem come from ?

Thank you.

Joe S. (Guest)
on 2006-05-05 18:02
(Received via mailing list)

Are you using soleb.rb application?  I ran into similar problems on an
app I
have been working with.  I was able to use soleb.rb to see how things
actually being exposed by the WIN32OLE libraries and found significant
variances between "spec" and "actual".
This topic is locked and can not be replied to.