Forum: Ruby on Rails Installation problems

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Neil J. (Guest)
on 2006-05-02 19:50
Complete newbite to ROR.

I have installed Ruby, RubyGems, & Rails according to the information at
the following url: http://xmlareas.com/ruby-rails-howto.html on a copy
of Fedora Core 4.

If I run the gem list command I can see the various packages including:
actionmailer(1.2.1)
rails(1.1.2)

However the installation instructions end and the next step is a
tutorial creating an application.  This instructs the use of the rails
command to start a new app.

On running the rails command I get the following:
-bash: rails: command not found

What's missing?
Charlie B. (Guest)
on 2006-05-03 20:59
(Received via mailing list)
This my sound silly but have you ran:
gem install rails?
Neil J. (Guest)
on 2006-05-03 21:34
yep

reads:
Local gem file not found: rails*gem
Attempting remote installation of 'rails'
Updating Gem source index for http://gems.rubyforge.org
Successfully installed rails-1.1.2

Then running the command: rails

I get:

bash: rails: command not found
Aadil V. (Guest)
on 2007-09-26 01:03
(Received via mailing list)
Hi Ziad,

Thanks for your help, it worked.

However, Is this something that I must do each time I restart, as I did
previously do this step, as suggested in the Installation instructions
on
the gnuradio website.

thanks again,

Aadil
This topic is locked and can not be replied to.