Forum: Ruby on Rails Setting up Rails Application on Apache

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Skulled (Guest)
on 2006-05-02 03:03

I am trying to setup a rails application on a webserver running Apache
1.3.34. But I have tried everything but its just not working.

I followed all the directions given here:

But whatever I do, the Rails welcome page doesn't show up. I am still
only getting an index listing when I try to access the page.

I ran the rails command to create the application outside of the
publick_html folder, and then set up the VirtualHost definitions and
everything properly I believe, but still no luck.

I would really appreciate if someone could point me to some resources on
how exactly to setup an application on a remote server.

Thanks for all the help in advance. :)
Brez! !. (Guest)
on 2006-05-02 10:52
You should post up the entries you made in your httpd.conf - that way we
can help troubleshoot..  are you trying to run regular cgi / fastcgi /

On a related note re. fastcgi - we've been using oracle's version of
apache [called OHS] - comes bundled with fastcgi and an assortment of
stuff. install is painless..  best/fastest way to get a fastcgi server
up and running [we did it in abt 6 minutes this morning, from nothing to
rails app using fastcgi].
rupakg (Guest)
on 2006-05-03 20:59
(Received via mailing list)
I had the same issue as I was running IIS on port 80. Please check your
apache configuration and make sure it is pointing to a different port
like 8080 etc. Hope it helps.

Rupak Ganguly
This topic is locked and can not be replied to.