Forum: GNU Radio Re: Basic USRP AM Transmission

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Robert R. (Guest)
on 2006-04-18 01:51
(Received via mailing list)
----- Original Message -----
From: Martin D. <removed_email_address@domain.invalid>
Date: Monday, April 17, 2006 3:06 pm
Subject: Re: [Discuss-gnuradio] Basic USRP AM Transmission
> > doing wrong?   Does my output need filtering before connecting to
> What is the sample_rate of the audio file
> What is you interpolation rate of the usrp
> What is the duc frequency of your usrp.

I have the file source sampled at 32kS/s

I use the following code for setting up my usrp:

        self.dac_rate = self.u.dac_rate()                    # 128 MS/s
        self.usrp_interp = 400
        self.u.set_interp_rate(self.usrp_interp)
        self.usrp_rate = self.dac_rate / self.usrp_interp    # 320 kS/s
        self.sw_interp = 10
        self.audio_rate = self.usrp_rate / self.sw_interp    # 32 kS/s

        # determine the daughterboard subdevice we're using
        if options.tx_subdev_spec is None:
            options.tx_subdev_spec = usrp.pick_tx_subdevice(self.u)

        m = usrp.determine_tx_mux_value(self.u, options.tx_subdev_spec)
        self.u.set_mux(m)
        self.subdev = usrp.selected_subdev(self.u,
options.tx_subdev_spec)
        print "Using TX d'board %s" % (self.subdev.side_and_name(),)

        self.subdev.set_gain(self.subdev.gain_range()[1])    # set max
Tx gain
        self.set_freq(options.freq)
        self.subdev.set_enable(True)                         # enable
transmitter


This is the same code I used for both a NFM and WFM transmitter, both of
which appeared to transmit without problems.

Sincerely,
~Chris~
Martin D. (Guest)
on 2006-04-18 09:05
(Received via mailing list)
Robert R. wrote:
>>>
>>>doing wrong?   Does my output need filtering before connecting to
>>440Hz tone
> I use the following code for setting up my usrp:
>             options.tx_subdev_spec = usrp.pick_tx_subdevice(self.u)
> transmitter
>
>
> This is the same code I used for both a NFM and WFM transmitter, both of
> which appeared to transmit without problems.
But do you actually put a software interpolator in there somewhere.
I didn't see any in your code:
>>>self.connect (src, const)
>>>self.connect (const, conv)
>>>self.connect (conv, gain)
>>>self.connect (gain, self.u)
should be:
self.connect (src, const)
self.connect (const, conv)
self.connect (conv, gain)
self.connect (gain, softwareinterpolator)
self.connect(softwareinterpolator,self.u)

greetings,
Martin
This topic is locked and can not be replied to.