Forum: Ruby on Rails Rails deployment

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Daan (Guest)
on 2006-04-14 19:44
Hi all,

I've greated a rails application and i want to deploy it right now.
I have to use a windows 2003 server.. So i installed

i've used the following tutorial:

http://wiki.rubyonrails.com/rails/pages/RailsOnWindows

My application is running at : http://loc.iwsweb.nl

But everytime i connect it opens a ruby process but at the end it won't
kill it.

As you can see the loading speed is horrible, but it's  a fast server
with a 100mbit connection.

Can anyone help me?

Thanks in advance,

Daan
Pedro V. (Guest)
on 2006-04-14 19:55
Daan wrote:
> Hi all,
>
> I've greated a rails application and i want to deploy it right now.
> I have to use a windows 2003 server.. So i installed
>
> i've used the following tutorial:
>
> http://wiki.rubyonrails.com/rails/pages/RailsOnWindows
>
> My application is running at : http://loc.iwsweb.nl
>
> But everytime i connect it opens a ruby process but at the end it won't
> kill it.
>
> As you can see the loading speed is horrible, but it's  a fast server
> with a 100mbit connection.
>
> Can anyone help me?
>
> Thanks in advance,
>
> Daan

Are you using Apache or Lighty?

Please post your .htaccess and the part of your httpd.conf that you
modified

P
http://wiki.onrails.com.ar
Daan (Guest)
on 2006-04-14 20:14
I'm using Apache

htaccess:
AddHandler fastcgi-script .fcgi
AddHandler cgi-script .cgi
Options +FollowSymLinks +ExecCGI

RewriteEngine On

RewriteRule ^$ index.html [QSA]
RewriteRule ^([^.]+)$ $1.html [QSA]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ dispatch.fcgi [QSA,L]

httpd.conf:

LoadModule rewrite_module modules/mod_rewrite.so
LoadModule fastcgi_module modules/mod_fastcgi.dll

DocumentRoot "C:/rails_docs/locaties/public"
<Directory "C:/rails_docs/locaties/public">

<VirtualHost *:80>
  ServerName rails
  DocumentRoot "C:/rails_docs/locaties/public"
  <Directory "C:/rails_docs/locaties/public">
    Options ExecCGI FollowSymLinks
    AllowOverride all
    Allow from all
    Order allow,deny
    AddHandler cgi-script .cgi
    AddHandler fastcgi-script .fcgi
  </Directory>
</VirtualHost>
Pedro V. (Guest)
on 2006-04-14 20:40
Daan wrote:
> I'm using Apache
>
> htaccess:
> AddHandler fastcgi-script .fcgi
> AddHandler cgi-script .cgi
> Options +FollowSymLinks +ExecCGI
>
> RewriteEngine On
>
> RewriteRule ^$ index.html [QSA]
> RewriteRule ^([^.]+)$ $1.html [QSA]
> RewriteCond %{REQUEST_FILENAME} !-f
> RewriteRule ^(.*)$ dispatch.fcgi [QSA,L]
>
> httpd.conf:
>
> LoadModule rewrite_module modules/mod_rewrite.so
> LoadModule fastcgi_module modules/mod_fastcgi.dll
>
> DocumentRoot "C:/rails_docs/locaties/public"
> <Directory "C:/rails_docs/locaties/public">
>
> <VirtualHost *:80>
>   ServerName rails
>   DocumentRoot "C:/rails_docs/locaties/public"
>   <Directory "C:/rails_docs/locaties/public">
>     Options ExecCGI FollowSymLinks
>     AllowOverride all
>     Allow from all
>     Order allow,deny
>     AddHandler cgi-script .cgi
>     AddHandler fastcgi-script .fcgi
>   </Directory>
> </VirtualHost>

IMHO Seems to be ok.

Ive readed that there are some issues with apache and fcgi. Search
google about that.
Lighttpd has better performance. Try lighty have you?
I used ligthy on my w2000 box.

P

http://wiki.onrails.com.ar
This topic is locked and can not be replied to.