Forum: Ruby on Rails Bug: Requiring "breakpoint" causes the entire Rails framewor

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Alder G. (Guest)
on 2006-04-14 19:36
(Received via mailing list)

I'm working with:

1. Ruby 1.8.4 (i386-mswin32)
2. RubyGems 0.8.11
3. Rails 1.1.2 (obtained through RubyGems)
4. ruby-breakpoint (0.5.0)

(Note that all of these are latest stable versions of the software)

Whenever I require 'breakpoint', the entire Rails framework  gets
loaded as well.

I tried "gem uninstall rails", and then require 'breakpoint' returned
false and didn't load Rails, but worked. I tried
uninstalling/reinstalling ruby-breakpoint - didn't help.

What should I do?  I want to use breakpoint outside of Rails, and
loading the Rails environment - is pretty taxing: nearly 400 files are
loaded, which takes several seconds every time.

Alder G.
This topic is locked and can not be replied to.