Forum: Ruby on Rails Uninitialized constant in a template for production server o

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Andrew F. (Guest)
on 2006-04-13 14:39
(Received via mailing list)
Not sure what is going on here, we are trying to push out a new
version of one of our tools to production. Everything works perfectly
in development (mac) and on our staging server (debian sarge) but the
prodution server (debian sarge) hates what we have done.

We have some variables set in the various environments *.rb file

One of them is a link to another product. It changes based on what
environments for example we have in development.rb the following set:

OTHER_PRODUCT = "localhost:3002"

in staging.rb we have:

OTHER_PRODUCT = "stage.server.url"

and in productionn.rb we have:

OTHER_PRODUCT = "production.server.url"

In the first two instances everything is fine, but in the production
server we always get a 500 error on any page that has a link_to set
to use that variable.

All servers are running rails 1.1.2 and ruby 1.8.4 any thoughts?

Andrew
Andrew F. (Guest)
on 2006-04-13 15:43
(Received via mailing list)
On a side note if i change the environment on the production server
from production to stage everything works fine except that my public
folder does not seem to be accessible as css and images do not appear
but I have a feeling that that issue is completely unrelated as when
i refresh I get a bad gateway error right away which probably has to
do with us using apache as a proxy and permission/setting issue which
is also causing me a fit since the production server is identicle in
everyway to our staging server. But making this change makes me
believe that it is indeed a rails issue as opposed to something
specific to my environment since changing the rails environment
causes things to work correctly.

Andrew
This topic is locked and can not be replied to.