Forum: Ruby on Rails Problem with freezing rails to vendor/rails

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Jim B. (Guest)
on 2006-04-10 11:12
my vendor dirrectory. But for some reason my app is still using the
locally installed gem versions of Rails on TXD. Running svn propget
svn:externals vendor returns:

rails http://dev.rubyonrails.org/svn/rails/tags/rel_1-1-1/


Here is the error I've been getting (app started using the TXD rails.sh
script):

NoMethodError (undefined method `const_load!' for Controllers:Module):
    /usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/dispatcher.rb:71:in
`prepare_application'
    /usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/dispatcher.rb:37:in
`dispatch'
    /usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/fcgi_handler.rb:141:in
`process_request'
    /usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/fcgi_handler.rb:53:in
`process!'
    /usr/local/lib/ruby/gems/1.8/gems/fcgi-0.8.6.1/./fcgi.rb:600:in
`each_cgi'
    /usr/local/lib/ruby/gems/1.8/gems/fcgi-0.8.6.1/./fcgi.rb:597:in
`each_cgi'
    /usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/fcgi_handler.rb:52:in
`process!'
    /usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/fcgi_handler.rb:22:in
`process!'
    /users/home/indylist/web/public/dispatch.fcgi:24


I am able to ntaract with my app using script/console production, I do
get the following error but everything seems to work fine otherwise:

Any thoughts on what I'm missing here?
This topic is locked and can not be replied to.