Forum: Rails Engines 1.1.1 engine breaks with gem rails

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Keith L. (Guest)
on 2006-04-07 06:49
Posted this to the rails group as well. Found that upgrading to Rails
1.1.1 and the engines plugin 1.1.1 caused web server to not start. The
solution turned out as follows:

The following code is in the new version of engines.rb:

begin
   require 'rails_version' # Rails 1.0, 1.1.0
 rescue LoadError
  require 'rails/version' # renamed as of Rails 1.1.1
end

but the exception from starting the web server is (Gem::Exception) from
the trace. Changing the above
to

begin
   require 'rails_version' # Rails 1.0, 1.1.0
 rescue
  require 'rails/version' # renamed as of Rails 1.1.1
end

allows the web server to start.

Keith
James A. (Guest)
on 2006-04-07 11:45
(Received via mailing list)
This error only seems to occur if you have BOTH Rails 1.1.0 and 1.1.1
gems installed (which is why I couldn't replicate it before).

It has been fixed in the official release, please update or reinstall
your version of the Engines plugin.

Cheers

- james

On 4/7/06, Keith L. <removed_email_address@domain.invalid> wrote:
> end
>
> http://lists.rails-engines.org/listinfo.cgi/engine...
>


--
* J *
  ~
This topic is locked and can not be replied to.