Forum: Ruby on Rails [ANN] Engines 1.1.1

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
James A. (Guest)
on 2006-04-07 03:29
(Received via mailing list)
Since a minor change in Rails (renaming the file that the version is
stored in, namely) causes a bit of a hiccup for the Engines plugin,
here's a new release, full of bug fixes and other nice things.

ALL users of Engines are advised to update their copy of the plugin to
get these fixes. The Engines plugin is fully backwards compatible with
Rails 1.0. Anyway - to update, please download either via the
script/plugin command, or (better) using SVN from:

  Latest Release (as ever): http://svn.rails-engines.org/plugins/engines
  Fixed Tag for 1.1.1:
http://svn.rails-engines.org/engines/tags/rel_1.1.1

As usual, when you are in the final stages of deploying a system for
production, I STRONGLY recommend using an SVN external pointing to a
tag (e.g. http://svn.rails-engines.org/engines/tags/rel_1.1.1) to
ensure your application will run as expected both now and in the
future.


What is this all about?
---------------------------------
Rails Engines is a mechanism for sharing maintainable code effectively
between your Rails applications. See http://rails-engines.org/ for
more....


CHANGELOG
---------------------
- Fixed migration rake task failing when given a specific version
(Ticket #115)
- Added new rake task "test:engines" which will test engines (and
other plugins) but ensure that the test database is cloned from
development beforehand (Ticket #125)
- Fixed issue where 'engine_schema_info' table was included in schema
dumps (Ticket #87)
- Fixed multi-part emails (Ticket #121)
- Added an 'install.rb' file to new engines created by the bundled
generator, which installs the engines plugin automatically if it
doesn't already exist (Ticket #122)
- Added a default VERSION module to generated engines (Ticket #123)
- Refactored copying of engine's public files to a method of an Engine
instance. You can now call Engines.get(:engine_name).copy_public_files
(Ticket #108)
- Changed engine generator templates from .rb files to .erb files
(Ticket #106)
- Fixed the test_helper.erb file to use the correct testing extensions
and not load any schema - the schema will be cloned automatically via
rake test:engines
- Fixed problem when running with Rails 1.1.1 where version wasn't
determined correctly (Ticket #129)


Problems / More Information
------------------------------------------
Please meander over to

  http://rails-engines.org

whereupon you will be guided to the most suitable place for more
information, questions and bug reports.


Cheers,

- james

--
* J *
  ~
Keith L. (Guest)
on 2006-04-07 04:58
James A. wrote:
> Since a minor change in Rails (renaming the file that the version is
> stored in, namely) causes a bit of a hiccup for the Engines plugin,
> here's a new release, full of bug fixes and other nice things.
>
> ALL users of Engines are advised to update their copy of the plugin to
> get these fixes. The Engines plugin is fully backwards compatible with
> Rails 1.0. Anyway - to update, please download either via the
> script/plugin command, or (better) using SVN from:
>
>   Latest Release (as ever): http://svn.rails-engines.org/plugins/engines
>   Fixed Tag for 1.1.1:
> http://svn.rails-engines.org/engines/tags/rel_1.1.1
>

Just upgraded to rails 1.1.1 and the engines 1.1.1 plugin. Now neither
mongrel nor webrick will start. Here's the error

=> Booting WEBrick...
/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:149:in `activate': can't
activate rails (= 1.1.0), already activated rails-1.1.1]
(Gem::Exception)
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:26:in
`require'
        from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
`require'
        from
./script/../config/../vendor/plugins/engines/lib/engines.rb:5
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
        from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
`require'
        from script/../config/../vendor/plugins/engines/init.rb:32:in
`load_plugin'
        from
/usr/local/lib/ruby/gems/1.8/gems/rails-1.1.1/lib/initializer.rb:348:in
`load_plugin'
        from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/core_ext/kernel/reporting.rb:11:in
`silence_warnings'
         ... 11 levels...
        from
/usr/local/lib/ruby/gems/1.8/gems/rails-1.1.1/lib/commands/server.rb:30
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
        from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
`require'
        from script/server:3

Any help appreciated.

Keith
Keith L. (Guest)
on 2006-04-07 06:10
I am using Rails in gems, not in the vendor directory. The following
code is in the new version of engines.rb:

begin
   require 'rails_version' # Rails 1.0, 1.1.0
 rescue LoadError
  require 'rails/version' # renamed as of Rails 1.1.1
end

but the exception is (Gem::Exception) from the trace. Changing the above
to

begin
   require 'rails_version' # Rails 1.0, 1.1.0
 rescue
  require 'rails/version' # renamed as of Rails 1.1.1
end

allows the web server to start.

Keith
James A. (Guest)
on 2006-04-07 11:45
(Received via mailing list)
This error only seems to occur if you have BOTH Rails 1.1.0 and 1.1.1
gems installed (which is why I couldn't replicate it before).

It has been fixed in the official release, please update or reinstall
your version of the Engines plugin.

Cheers

- james

On 4/7/06, Keith L. <removed_email_address@domain.invalid> wrote:
> >   Latest Release (as ever): http://svn.rails-engines.org/plugins/engines
> (Gem::Exception)
> `require'
> `silence_warnings'
>
>
--
* J *
  ~
James A. (Guest)
on 2006-04-07 11:45
(Received via mailing list)
This error only seems to occur if you have BOTH Rails 1.1.0 and 1.1.1
gems installed (which is why I couldn't replicate it before).

It has been fixed in the official release, please update or reinstall
your version of the Engines plugin.

Cheers

- james

On 4/7/06, Keith L. <removed_email_address@domain.invalid> wrote:
> to
>
>
> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> Rails mailing list
> removed_email_address@domain.invalid
> http://lists.rubyonrails.org/mailman/listinfo/rails
>


--
* J *
  ~
This topic is locked and can not be replied to.