Forum: Ruby on Rails exception_notification crashes fast_cgi process

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Ian W. (Guest)
on 2006-04-04 13:31
(Received via mailing list)
Hi List,

I'm using FastCGI on apache 1.3 and rails 1.8.2

When an execption notification occurs (whether it's a 404 or 500) my
FastCGI process dies.  I'm find it hard to get at the error, as
there's no debug info in any of the logs (production.log, server
error.log or fastcgi crach log).

I've enabled noisy mailer errors, but nothing's showing up.

Any pointers?

Cheers,
Ian


ps.  Here's the log

First this happens (production.log)

Rendering /home/sites/home/dwapp/public/../config/../public/404.html
(404 Not Found)

(looks good)

Then this happens (in apache error.log)

[Tue Apr  4 10:20:22 2006] [warn] FastCGI: server
"/home/sites/home/dwapp/public/dispatch.fcgi" (pid 13396) terminated
by calling exit with status '1'
[Tue Apr  4 10:20:22 2006] [warn] FastCGI: server
"/home/sites/home/dwapp/public/dispatch.fcgi" restarted (pid 13543)
[Tue Apr  4 10:20:22 2006] [error] [client 82.38.203.45] FastCGI:
incomplete headers (0 bytes) received from server
"/home/sites/home/dwapp/public/dispatch.fcgi"

(doh!)

The same for 500 errors.
Ian W. (Guest)
on 2006-04-04 13:49
(Received via mailing list)
BTW. problem happens with ruby 1.8.4
This topic is locked and can not be replied to.