Forum: Ruby on Rails How to create new rails 1.1 app if only rails 1.0 installed?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Peter G. (Guest)
on 2006-04-03 23:16
I have rails 1.0 and I cannot install rails-1.1 system-wide.

However, I can freeze_edge (but just once because of svn 1.1.4 on
Debian).

Under this scenario, how can I create brand new rails-1.1 apps?

I know how to freeze_edge *existing* rails-1.0 apps but that process
seems to be imperfect because the script/about command and
/rails/info/properties URL do not work after freezing to 1.1.0 release
or revision 4142.
Jeff C. (Guest)
on 2006-04-03 23:21
Peter G. wrote:
> I have rails 1.0 and I cannot install rails-1.1 system-wide.
>
> However, I can freeze_edge (but just once because of svn 1.1.4 on
> Debian).
>
> Under this scenario, how can I create brand new rails-1.1 apps?
>
> I know how to freeze_edge *existing* rails-1.0 apps but that process
> seems to be imperfect because the script/about command and
> /rails/info/properties URL do not work after freezing to 1.1.0 release
> or revision 4142.

DHH posted about this--
http://weblog.rubyonrails.com/articles/2006/04/03/...

--suggesting the best way is to check out the Rails trunk from SVN.

Jeff
Peter G. (Guest)
on 2006-04-03 23:51
Jeff C.man wrote:
> Peter G. wrote:
>> I have rails 1.0 and I cannot install rails-1.1 system-wide.
>>
>> However, I can freeze_edge (but just once because of svn 1.1.4 on
>> Debian).
>>
>> Under this scenario, how can I create brand new rails-1.1 apps?
>>
>> I know how to freeze_edge *existing* rails-1.0 apps but that process
>> seems to be imperfect because the script/about command and
>> /rails/info/properties URL do not work after freezing to 1.1.0 release
>> or revision 4142.
>
> DHH posted about this--
> 
http://weblog.rubyonrails.com/articles/2006/04/03/...
>
> --suggesting the best way is to check out the Rails trunk from SVN.
>
> Jeff

I have the ability to upgrade individual 1.0 apps to 1.1 using
freeze_edge.

But I want to create individual 1.1 apps from scratch.

Why? Because upgraded apps don't seem to support the 'rails_info' or
'rails/info' URL and the 'script/about' command fails too (only after
upgrade).

Assuming I cannot change /usr/bin/rails -- how can I create individual
rails 1.1 apps?

Thanks.
James L. (Guest)
on 2006-04-04 00:01
(Received via mailing list)
On 4/3/06, Peter G. <removed_email_address@domain.invalid> wrote:
> rails 1.1 apps?
If you all you want is the skeleton of the app that the rails command
generates, why don't you run that command on a different machine (that
has Rails 1.1 installed) and then just copy the skeleton?
Trevor S. (Guest)
on 2006-04-04 00:25
(Received via mailing list)
Hi Peter,

how about something like this:

mkdir mynewproject
mkdir mynewproject/vendor
cd mynewproject/vendor
svn export http://dev.rubyonrails.org/svn/rails/tags/rel_1-1-0 rails
cd ../
ruby vendor/rails/railties/bin/rails .

Regards,
Trevor

--
Trevor S.
http://somethinglearned.com
This topic is locked and can not be replied to.