Forum: Ruby TkHTML progress, additional questions

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Randy K. (Guest)
on 2006-04-03 20:05
(Received via mailing list)

I finally made some progress setting up TkHTML and getting it to run
both as a
Ruby script and within irb.  (The most basic thing I have to do is start
(or Ruby) with prefixes like:

(or ruby)

Somebody had told me that before, but it didn't seem to work before (I
did a reinstall, so maybe that is the difference).  (And, unfortunately,
have to do another reinstall in the "near" future (maybe not for a few
because once again, readline did not get compiled in (but that was
because I
had renamed readline.h a week or so ago to do some experimentation and
to rename it back.)

Minor point (for me) to remember--some of the examples I tried did not
the Tk.mainloop statement--worked much better after I added that ;-)


1.  Fonts:  The fonts don't look too good--I presume that when I learn
about TkHTML, I'll find a way to change the fonts, maybe not by the
user, but
hopefully within Ruby?  (I'm hoping not to have to fool around in C,
C++, tcl
or whatever to change fonts.)

2.  Background:  When I run either hv.rb or ss.rb, I get a nice white
background (i.e., this is what I want).  When I run (this) sample
within irb:

require 'tk'
require 'tkextlib/tkHTML'
doc = "<body bgcolor=\"#FFFFFF\"><FONT SIZE=\"3\" COLOR=\"#000000\"
FACE=\"Courier,serif\"><b>It is</b> worth</FONT></body>"
hv =

I get a gray background, which I don't want.  I presume I'll find a way
change this to white as well, hopefully within ruby (or maybe my HTML is
totally wrong (which wouldn't surprise me))?

3.  Full Screen mode:

When I run ss.rb and switch to full screen mode on my dual head machine,
widget expands to fully cover both "heads".

Furthermore, I can't find a way to get of full screen mode except by
to a VT, then finding and killing the process.   (I've tried <alt>f,f
some other things I could think of.)  Is there another way?

Note: These points about full screen mode are probably not a big
probably just disable full screen mode on the ss.rb menu (if I use
like ss.rb).

Randy K.
This topic is locked and can not be replied to.