Forum: Ruby on Rails Problem installing Rails

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Keng onn W. (Guest)
on 2006-04-01 20:24
(Received via mailing list)
Hi,

I can't seem to get gem to install rails on my machine :(. What I see
displayed is this: (after running

"gem install rails --include-dependencies"

===
Upgrading installed gems..
Updating Gem source index for: http://gems.rubyforge.org
ERROR: While executing gem ... (Errno::EINVAL)
    Invalid argument
===

I've tried googling for answers and tried basically everything I could,
including disabling my firewall

and switching off my anti-virus, attaching "--http-proxy" to the install
command, and resetting my

winsock (via "netsh winsock reset"). Nothing seems to work :(. I can't
even run "gem update"...

I'd really appreciate any help on this matter.

Thanks in advance!
This topic is locked and can not be replied to.