Forum: Typo "Guid has already been taken" error

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Cory Vander J. (Guest)
on 2006-04-01 01:28
(Received via mailing list)
hello -

sorry for the spam if there is a better place to look for this sort of
thing, but my old install of typo started acting strangely the other day
so
i tried to upgrade.  i wasn't having much luck, so i did a fresh install
of
the latest trunk release (977 i believe) and then imported my old
articles
from a text file.

that worked fine, except now, when i try to post a new article i get the
following error:

1 error prohibited this article from being saved
>
> There were problems with the following fields:
>
>     * Guid has already been taken
>

I've tried changing and even deleting the old guid's from the database
but
that doesn't help.  any suggestions?

thanks.
Dick D. (Guest)
on 2006-04-01 11:02
(Received via mailing list)
What database is it?

On 31/03/06, Cory Vander J. <removed_email_address@domain.invalid> wrote:
>
> thanks.
>
> _______________________________________________
> Typo-list mailing list
> removed_email_address@domain.invalid
> http://rubyforge.org/mailman/listinfo/typo-list
>
>


--
Rasputin :: Jack of All Trades - Master of Nuns
http://number9.hellooperator.net/
Kevin B. (Guest)
on 2006-04-01 11:08
(Received via mailing list)
That error tends to happen if you have any guids set to NULL. I don't
know how people end up with NULL guids, but it's happened in the past
and caused this error.
This topic is locked and can not be replied to.