Forum: Ruby can activesupport gem be used in "standalone" fashion?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
john peter (Guest)
on 2006-04-01 00:12
(Received via mailing list)
i'm using ruby 1.8.2, rubygem 0.8.10, rails 1.0.0 where activesupport
version = 1.2.5

when i try to run this in RADRail, i get a NoMethodError:

require 'rubygems'
require_gem "activesupport"

print Time.now + 2.days

the error message is: c:/e312workspace/first/test3.rb:5: undefined
method `days' for 2:Fixnum (NoMethodError)

is there a way to use the numeric/time core_ext in a plain ruby app? if
so, how?
thanks for any help!
Michael G. (Guest)
on 2006-04-01 00:18
(Received via mailing list)
I'm not sure why the above doesn't work, but check below for a working
version.

powerbook:~ michaelguterl$ irb
irb(main):001:0> require 'rubygems'
=> true
irb(main):002:0> require 'active_support'
=> true
irb(main):003:0> Time.now + 2.days
=> Sun Apr 02 16:16:22 EDT 2006
irb(main):004:0>
john peter (Guest)
on 2006-04-01 00:24
(Received via mailing list)
Thanks! That worked. Not sure what was wrong with require_gem

Michael G. <removed_email_address@domain.invalid> wrote: I'm not sure why the 
above
doesn't work, but check below for a working
version.

powerbook:~ michaelguterl$ irb
irb(main):001:0> require 'rubygems'
=> true
irb(main):002:0> require 'active_support'
=> true
irb(main):003:0> Time.now + 2.days
=> Sun Apr 02 16:16:22 EDT 2006
irb(main):004:0>
Logan C. (Guest)
on 2006-04-01 01:04
(Received via mailing list)
On Mar 31, 2006, at 3:23 PM, john peter wrote:

> Thanks! That worked. Not sure what was wrong with require_gem
>

Nothing is wrong with require_gem. It has an unfortunate name though.
It should really be called activate_gem or something similar.
require_gem only actually require's the library if it uses
autorequire, which is deprecated now.
require_gem is to select things like a given version of a gem, ie:
require_gem 'some_gem', '>= 1.0'
you still have to do the
require 'some_gem' line
john peter (Guest)
on 2006-04-01 01:53
(Received via mailing list)
thanks!

Logan C. <removed_email_address@domain.invalid> wrote:
On Mar 31, 2006, at 3:23 PM, john peter wrote:

> Thanks! That worked. Not sure what was wrong with require_gem
>

Nothing is wrong with require_gem. It has an unfortunate name though.
It should really be called activate_gem or something similar.
require_gem only actually require's the library if it uses
autorequire, which is deprecated now.
require_gem is to select things like a given version of a gem, ie:
require_gem 'some_gem', '>= 1.0'
you still have to do the
require 'some_gem' line
This topic is locked and can not be replied to.