Forum: Ruby on Rails AAARGH! Need some fresh eyes to look at this pls

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Robbie S. (Guest)
on 2006-03-31 04:19
I just switched my rails app over to production mode, couldn't get it
working, switched it back to development mode, and now nothing gets
outputted in the browser. I'm sure I've missed something in the configs.

Setup: Lighttpd/SCGI on WinXP, Rails 1.0.

Environment.rb:
ENV['RAILS_ENV'] ||= 'development'

require File.join(File.dirname(__FILE__), 'boot')

Rails::Initializer.run do |config|
end

database.yaml:
development:
  adapter: mysql
  database: extranet
  username: xxxxx
  password: xxxxxxxx
  socket: /path/to/your/mysql.sock

scgi.yaml
:password: xxxxxxxxxxxx
:control_url: druby://127.0.0.1:8999
:port: 9999
:config: config/scgi.yaml
:logfile: log/scgi.log
:env: development
:host: 127.0.0.1
:disable_signals: true

lighttpd.conf:
server.modules = (
            "mod_rewrite",
            "mod_redirect",
            "mod_access",
            "mod_accesslog",
            "mod_status",
			"mod_scgi"
)
server.document-root        = "C:/rails/extranet/public/"
server.errorlog             = "C:/rails/extranet/log/lighttpd.error.log"
accesslog.filename          = "C:/rails/extranet/log/access.log"
server.max-request-size		= 2097152
server.max-keep-alive-idle = 0
server.max-keep-alive-requests = 0
$HTTP["useragent"] =~ "^(.*MSIE.*)|(.*AppleWebKit.*)$" {
   server.max-keep-alive-requests = 0
}
#some other stuff removed for this forum post
static-file.exclude-extensions = ( ".php", ".pl", ".fcgi", ".scgi" )
server.error-handler-404   = "/dispatch.scgi"

scgi.server = ("dispatch.scgi" => ((
				"host" => "127.0.0.1",
				"port" => 8999,
				"check-local" => "disable"
				)) )
scgi.debug = 2
status.status-url = "/server-status"
status.config-url = "/server-config"

scgi.log:
[INF][988] Running in development mode on 127.0.0.1:9999

lighttpd.error.log:
2006-03-31 09:59:56: (mod_scgi.c.2029) proc: 127.0.0.1 8999  1 0 0 0
2006-03-31 09:59:57: (mod_scgi.c.2029) proc: 127.0.0.1 8999  1 0 0 0
2006-03-31 09:59:58: (mod_scgi.c.2029) proc: 127.0.0.1 8999  1 0 0 0
2006-03-31 09:59:59: (mod_scgi.c.2029) proc: 127.0.0.1 8999  1 0 0 0
2006-03-31 10:00:00: (mod_scgi.c.2029) proc: 127.0.0.1 8999  1 0 0 0
2006-03-31 10:00:02: (log.c.75) server started
2006-03-31 10:00:45: (mod_scgi.c.1325) connect delayed, will continue
later: 7
2006-03-31 10:00:45: (mod_scgi.c.2239) got proc: 7 0  8999 1
2006-03-31 10:00:45: (mod_scgi.c.1179) release proc: 7 0
2006-03-31 10:00:45: (mod_scgi.c.2029) proc: 127.0.0.1 8999  1 0 0 0

(this error log constantly updates every second with the same info
roughly)


It's been working fine for ages, now I can't get it running. Now nothing
gets outputted to the browser, nothing is being written to the
development.log file, and I'm in deep deep sh#t!
Robbie S. (Guest)
on 2006-03-31 04:36
had the port number wrong in the lighttpd.conf...fixed.
Wilson B. (Guest)
on 2006-03-31 04:37
(Received via mailing list)
On 3/30/06, robbie shepherd <removed_email_address@domain.invalid> wrote:
> :env: development
> :host: 127.0.0.1
> :disable_signals: true
>
> scgi.server = ("dispatch.scgi" => ((
>                                 "host" => "127.0.0.1",
>                                 "port" => 8999,
>                                 "check-local" => "disable"
>                                 )) )

You've got the port numbers in 'port' and 'control_url' mixed up in
your scgi.yml file, looks like.

--Wilson.
This topic is locked and can not be replied to.