Forum: Ruby on Rails Rails 1.1 and Ruby 1.8.3

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Greg F. (Guest)
on 2006-03-31 03:45
(Received via mailing list)
I've seen that Rails 1.1 is not reliable with Ruby 1.8.2 so you should
upgrade to 1.8.4

I'm running ruby 1.8.3.  What's the story with it?  Do I need to
upgrade before I try Rails 1.1?

Thanks
Greg
--
Greg F.
The Norcross Group
Forensics for the 21st Century
Nshbrown N. (Guest)
on 2006-03-31 04:06
(Received via mailing list)
Rails fastcgi simply wont run with Ruby 1.8.3. So I suppose you do need
to
upgrade :)

-Nb

On 3/30/06 3:41 PM, "Greg F." <removed_email_address@domain.invalid> wrote:

> The Norcross Group
> Forensics for the 21st Century
> _______________________________________________
> Rails mailing list
> removed_email_address@domain.invalid
> http://lists.rubyonrails.org/mailman/listinfo/rails

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Nathaniel S. H. Brown                        http://nshb.net
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Greg F. (Guest)
on 2006-03-31 04:15
(Received via mailing list)
Weird,

I'm running lighty with fcgi and Rails 1.0 now.

So does your statement only apply to Apache setups?

Greg

On 3/30/06, Nathaniel B. <removed_email_address@domain.invalid> wrote:
> > I'm running ruby 1.8.3.  What's the story with it?  Do I need to
> > removed_email_address@domain.invalid
> _______________________________________________
> Rails mailing list
> removed_email_address@domain.invalid
> http://lists.rubyonrails.org/mailman/listinfo/rails
>


--
Greg F.
The Norcross Group
Forensics for the 21st Century
Jeff C. (Guest)
on 2006-03-31 05:51
Greg F. wrote:
> I'm running ruby 1.8.3.  What's the story with it?  Do I need to
> upgrade before I try Rails 1.1?

Definitely do not use 1.83 with Rails 1.1:
http://www.rubyonrails.com/down

and see Kent's comment to this post:
http://www.softiesonrails.com/articles/2006/03/28/...

Upgrade to 1.84 or you can go back down to 1.82 if you prefer.

Jeff
www.softiesonrails.com
Craig W. (Guest)
on 2006-03-31 06:38
(Received via mailing list)
On Thu, 2006-03-30 at 16:04 -0800, Nathaniel B. wrote:
> Rails fastcgi simply wont run with Ruby 1.8.3. So I suppose you do need to
> upgrade :)
----
huh?

# ps aux|grep cgi
apache   11714  0.0  0.6 15652 7112 ?        S    Mar27
0:00 /usr/sbin/fcgi-
apache   11715  0.0  2.1 26016 21916 ?       S    Mar27
0:29 /usr/bin/ruby /home/craig/th-db/public/dispatch.fcgi
apache   11726  0.0  2.1 24524 21808 ?       S    Mar27
0:38 /usr/bin/ruby /home/craig/th-db/public/dispatch.fcgi
apache   11727  0.0  1.6 21676 17324 ?       S    Mar27
0:02 /usr/bin/ruby /home/craig/th-db/public/dispatch.fcgi
apache   11728  0.0  1.4 22212 15396 ?       S    Mar27
0:02 /usr/bin/ruby /home/craig/th-db/public/dispatch.fcgi
apache   11729  0.0  2.1 25016 21916 ?       S    Mar27
0:03 /usr/bin/ruby /home/craig/th-db/public/dispatch.fcgi
apache   11730  0.0  2.1 26244 21764 ?       S    Mar27
0:59 /usr/bin/ruby /home/craig/th-db/public/dispatch.fcgi
apache   11731  0.0  2.1 25744 21964 ?       S    Mar27
0:18 /usr/bin/ruby /home/craig/th-db/public/dispatch.fcgi
apache   11732  0.0  2.0 25828 21632 ?       S    Mar27
1:53 /usr/bin/ruby /home/craig/th-db/public/dispatch.fcgi
apache   11733  0.0  1.6 21884 16980 ?       S    Mar27
0:02 /usr/bin/ruby /home/craig/th-db/public/dispatch.fcgi
apache   11736  0.0  2.0 25972 21680 ?       S    Mar27
0:31 /usr/bin/ruby /home/craig/th-db/public/dispatch.fcgi
apache   11737  0.0  2.0 26288 21548 ?       S    Mar27
0:34 /usr/bin/ruby /home/craig/th-db/public/dispatch.fcgi
apache   11738  0.0  2.1 24500 21760 ?       S    Mar27
1:14 /usr/bin/ruby /home/craig/th-db/public/dispatch.fcgi
apache   11739  0.0  2.0 25080 21740 ?       S    Mar27
0:41 /usr/bin/ruby /home/craig/th-db/public/dispatch.fcgi
apache   11740  0.0  2.0 25640 21556 ?       S    Mar27
0:33 /usr/bin/ruby /home/craig/th-db/public/dispatch.fcgi
apache   11741  0.0  1.9 25948 20376 ?       S    Mar27
0:50 /usr/bin/ruby /home/craig/th-db/public/dispatch.fcgi

# rpm -qa|grep ruby
ruby-libs-1.8.3-2.c4
ruby-docs-1.8.3-2.c4
ruby-1.8.3-2.c4
ruby-devel-1.8.3-2.c4
ruby-mode-1.8.3-2.c4

# ls -l /tmp/*fcgi*
total 12
srw-------  1 apache apache    0 Mar 27 08:20
21e9bf3e1a3ca6ddbb8ec51e39e0453a
drwx------  2 apache apache 4096 Mar 22 22:46 dynamic

# ls -ld /tmp/*fcgi*
drwx------  3 apache apache 4096 Mar 27 08:20 /tmp/fcgi_ipc


Craig
----
Berlin B. (Guest)
on 2006-03-31 06:50
(Received via mailing list)
Jeff C. wrote:

>
>and see Kent's comment to this post:
>http://www.softiesonrails.com/articles/2006/03/28/...
>
>Upgrade to 1.84 or you can go back down to 1.82 if you prefer.
>
>Jeff
>www.softiesonrails.com
>
>
>
And I know that the current Ubunutu is set a Ruby 1.8.3.  I know a lot
of people are using ubuntu.  I actually didnt have any problems with it
(for 1.0 anyway).

--
Berlin B.
(ramaza3 on freenode)
http://www.newspiritcompany.com
also checkout alpha version of botverse:
http://www.newspiritcompany.com:8086/universe_home
Nshbrown N. (Guest)
on 2006-03-31 07:11
(Received via mailing list)
I would show you the error I got but my production server is already
updated.

You are sure you are running Rails 1.1 on that fastcgi process and not
1.0?

-Nb


On 3/30/06 6:37 PM, "Craig W." <removed_email_address@domain.invalid> wrote:

> 0:29 /usr/bin/ruby /home/craig/th-db/public/dispatch.fcgi
> apache   11731  0.0  2.1 25744 21964 ?       S    Mar27
> 1:14 /usr/bin/ruby /home/craig/th-db/public/dispatch.fcgi
> ruby-1.8.3-2.c4
> drwx------  3 apache apache 4096 Mar 27 08:20 /tmp/fcgi_ipc
>>> upgrade to 1.8.4
>>> _______________________________________________
>>
>>
>> _______________________________________________
>> Rails mailing list
>> removed_email_address@domain.invalid
>> http://lists.rubyonrails.org/mailman/listinfo/rails
>
> _______________________________________________
> Rails mailing list
> removed_email_address@domain.invalid
> http://lists.rubyonrails.org/mailman/listinfo/rails

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Nathaniel S. H. Brown                        http://nshb.net
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Craig W. (Guest)
on 2006-03-31 07:27
(Received via mailing list)
Oh no - I am running Rails 1.0 and fully intend to update over the
weekend to ruby 1.8.4 before updating to Rails 1.1 as this is a
production server. I was merely responding to your statement that Rails
fastcgi simply won't run with Ruby 1.8.3 and thought the subject does
say Rails 1.1, your statement seemed to encompass Rails 1.0.

So far, my usage on my development system hasn't broken with Rails 1.1
but I haven't tested everything out yet.

Craig
Blair Z. (Guest)
on 2006-04-02 20:45
(Received via mailing list)
Berlin B. wrote:
>> Definitely do not use 1.83 with Rails 1.1:
>>
>>
>>
> And I know that the current Ubunutu is set a Ruby 1.8.3.  I know a lot
> of people are using ubuntu.  I actually didnt have any problems with it
> (for 1.0 anyway).

I have Ruby 1.8.4 packages for Ubuntu Breezy badger that were backported
from
Debian unstable.

See

http://www.orcaware.com/packages/ubuntu/breezy/

Regards,
Blair

--
Blair Z., Ph.D.
<removed_email_address@domain.invalid>
Subversion training, consulting and support
http://www.orcaware.com/svn/
jack (Guest)
on 2006-04-03 06:37
wondering what is the proper way to upgrade on Ubuntu Breezy - install
ruby and libruby  1.8.4 from packages (either from orcaware or dapper) -
then what?  download and install gems from source ?  thks.


Blair Z. wrote:
> Berlin B. wrote:
>>> Definitely do not use 1.83 with Rails 1.1:
>>>
>>>
>>>
>> And I know that the current Ubunutu is set a Ruby 1.8.3.  I know a lot
>> of people are using ubuntu.  I actually didnt have any problems with it
>> (for 1.0 anyway).
>
> I have Ruby 1.8.4 packages for Ubuntu Breezy badger that were backported
> from
> Debian unstable.
>
> See
>
> http://www.orcaware.com/packages/ubuntu/breezy/
>
> Regards,
> Blair
>
> --
> Blair Z., Ph.D.
> <removed_email_address@domain.invalid>
> Subversion training, consulting and support
> http://www.orcaware.com/svn/
This topic is locked and can not be replied to.