Forum: Ruby on Rails Dreamhosters beware: 1.1 migration ruckus

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Juan Lupión (Guest)
on 2006-03-29 10:48
(Received via mailing list)
This will probably demolish your Typo-based weblog and cause some
other glitches.  Read the comments and some workarounds here:

http://blog.dreamhost.com/2006/03/28/new-rails/

--
Josh S. (Guest)
on 2006-03-29 11:13
Juan Lupión wrote:
> This will probably demolish your Typo-based weblog and cause some
> other glitches.  Read the comments and some workarounds here:
>
> http://blog.dreamhost.com/2006/03/28/new-rails/

I've got a workaround recipe on my blog. The one I posted on the DH blog
doesn't really work (I was too eager to post it to make sure it was
really working), but their spam protection won't let me post there
again. Updated recipe here:

http://blog.hasmanythrough.com/articles/2006/03/28...

It's working for my blog now.

--
Josh S.
http://blog.hasmanythrough.com
Tom W. (Guest)
on 2006-03-29 18:36
(Received via mailing list)
I have to say that it's a pretty good idea to run with your own
version of Rails if you are on a shared host ? any shared host. This
would be one really good reason. I have two sites on DH and they both
have been on Edge Rails for months and didn't blink with this change.

Here's how I set up Typo on Edge Rails:

http://convergentarts.com/articles/2005/11/30/typo...

-Tom
Scott B. (Guest)
on 2006-03-29 21:42
(Received via mailing list)
Here's how to fix it and use one copy of the gems and symlink it to
multiple apps:

http://synthesis.sbecker.net/articles/2006/03/29/r...

--
Scott B.
Web D.
http://synthesis.sbecker.net

Electro Interactive
http://www.ElectroInteractive.com
Jón B. (Guest)
on 2006-03-29 23:56
(Received via mailing list)
There is actually a svn branch of typo on that seems to work for rails
1.1.
I have tested it on my local machine and it seems to work ok. Going to
test it a little more before installing it on my main server but I am
yet to find a bug.

http://www.typosphere.org/trac/browser/branches/rails_1_1

Just remember to backup the old installation and do a mysqldump of the
database before installing. Also don't forget the rake migrate command
as there is a few database changes.


--
--------------
Jon Gretar B.
http://www.jongretar.net/
This topic is locked and can not be replied to.