Forum: Ruby on Rails xmlsimple not found

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Nikki (Guest)
on 2006-03-29 06:57
I've been working through the Flickr tutorial, and it looks like I
installed the Flickr gem with the require xml-simple gem without
problems.  But when I got to the point in the demo when it was time to
submit the form, I got an error with the message "uninitialized constant
Flickr".

I did some poking around at the gem repository, and ran 'ruby
test_flickr.rb' to test, and got the message:
./flickr.rb:49:in `require': no such file to load -- xmlsimple
(LoadError). This is of course the place in flickr.rb where "require
'xmlsimple'" is called.  Ran a similar test in a test.rb file that
simply says "require 'xmlsimple'", and it chokes in a similar fashion.

The system says I have xml-simple installed (running gem q -l). I've
tried uninstalling and reinstalling both xml-simple and flickr,
independendtly and by letting flickr grab xml-simple. I've restarted the
server entirely. Things always install without error, and gem always
tells me I've got xml-simple installed, but when it comes time to
require xmlsimple, it can't be found.  I'm tearing my hair out.

I've got xml-simple 1.0.8, Ruby 1.8.4, RubyGems 0.8.11, running on an
old Suse 8 box.  Haven't had any problems running or installing anything
Ruby-on-Rails related so far.

Thanks,

Nikki
Nikki (Guest)
on 2006-03-29 23:56
A bit more information - turns out I can't find any extra installed
gems.  Running gem env produces:
Rubygems Environment:
  - VERSION: 0.8.11 (0.8.11)
  - INSTALLATION DIRECTORY: /usr/local/lib/ruby/gems/1.8
  - GEM PATH:
     - /usr/local/lib/ruby/gems/1.8
  - REMOTE SOURCES:
     - http://gems.rubyforge.org

The gem path seems to be correct.  I tried additionally adding a similar
$GEM_HOME to my local environment.  I have "export RUBYOPT=rubygems" in
my .profile.  Gems install without error and show that they're installed
on the server.  I'm using the mysql gem to connect to the database
without problem. But when I run something at the command line like 'ruby
require flickr', I get "No such file or directory -- require
(LoadError)".

Aside from wanting to muck around with the simple Flickr demo, I'd
really like to figure out what's up with my system so I can use the
extra libraries.

Thanks,

Nikki
Nikki (Guest)
on 2006-03-30 00:45
Final comment - I just installed Ruby/Gems/Rails on my WinXP laptop and
I'm getting the exact same results.  Everything seemed to install
without error.  I can run a basic app.  I install the Flickr gem, which
also grabs xml-simple. The system says they're installed.  Go to run
'ruby require flickr' and bam - can't be found. Gem_path seems to point
to the correct repository.

Is there a version incompatibility somewhere? Both systems (Linux and
Windows) are running Ruby 1.8.4, Gems 1.8, Rails 1.1, flickr gem 1.0.0,
xml-simple 1.0.8 (though I tried to grab the Technorati gem, which
installed, and the system couldn't find that either.

I was really looking forward to teaching myself RoR with a demo app I
have in mind, but I'm close to giving up.

Thanks again,

Nikki
David T. (Guest)
on 2006-03-30 01:18
(Received via mailing list)
Try running ruby -e "require 'flickr'" and see if that works. Just
running ruby require flickr will try to execute a script called
require, which obviously isn't what you're trying to achieve.

Hope that helps.

David
Nikki (Guest)
on 2006-03-30 02:33
That doesn't work either (and obviously I'm a newbie).

I ran

ruby -e "require 'flickr'"

and got -e:1:in `require': no such file to load -- flickr (LoadError)
        from -e:1

And as long as - require 'flickr' - is in the environment.rb file, I
can't start the server, generate scaffolds, etc.

Thanks very much for answering though.

Nikki
This topic is locked and can not be replied to.