Forum: Ruby on Rails Capistrano deployment issues under Ubuntu Dapper

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Jamie M. (Guest)
on 2006-03-28 01:48
(Received via mailing list)
I've recently upgraded my box from Ubuntu Breezy to Dapper, and for
the life of me can't figure out why I'm getting this exception thrown.

I've switched from Switchtower to Capistrano, and when I run rake
deploy I get this output:


 ** [update_code] exception while rolling back: NameError,
uninitialized constant Net::SSH::Transport::OSSL
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require__': no such file to load -- openssl (LoadError)
        from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
        from
/usr/lib/ruby/gems/1.8/gems/net-ssh-1.0.8/lib/net/ssh/transport/ossl/services.rb:17
        from
/usr/lib/ruby/gems/1.8/gems/needle-1.3.0/lib/needle/container.rb:354:in
`require'
        from
/usr/lib/ruby/gems/1.8/gems/needle-1.3.0/lib/needle/definition-context.rb:77:in
`require'
        from
/usr/lib/ruby/gems/1.8/gems/net-ssh-1.0.8/lib/net/ssh/transport/services.rb:137:in
`register_services'
        from
/usr/lib/ruby/gems/1.8/gems/needle-1.3.0/lib/needle/container.rb:107:in
`define'
        from
/usr/lib/ruby/gems/1.8/gems/needle-1.3.0/lib/needle/container.rb:250:in
`namespace_define'
        from
/usr/lib/ruby/gems/1.8/gems/needle-1.3.0/lib/needle/container.rb:177:in
`namespace'
         ... 29 levels...
        from
/usr/lib/ruby/gems/1.8/gems/capistrano-1.1.0/lib/capistrano/cli.rb:221:in
`execute!'
        from
/usr/lib/ruby/gems/1.8/gems/capistrano-1.1.0/lib/capistrano/cli.rb:12:in
`execute!'
        from /usr/lib/ruby/gems/1.8/gems/capistrano-1.1.0/bin/cap:11
        from /usr/bin/cap:18


I've googled around and haven't seen anything particularly useful.
I've got an up-to-date-as-of-this-morning dapper, and the following
gems installed (pretty much rails + nitro):

actionmailer (1.1.5)
actionpack (1.11.2)
actionwebservice (1.0.0)
activerecord (1.13.2)
activesupport (1.2.5)
BlueCloth (1.0.0)
capistrano (1.1.0)
cmdparse (2.0.0)
daemons (0.4.2)
facets (1.2.0, 1.1.0, 1.0.3)
gen (0.29.0)
glue (0.29.0)
needle (1.3.0)
net-sftp (1.1.0)
net-ssh (1.0.8)
nitro (0.29.0)
og (0.29.0)
rails (1.0.0)
rake (0.7.0)
RedCloth (3.0.4, 3.0.3)
ruby-breakpoint (0.5.0)
rubygems-update (0.8.11)
sources (0.0.1)
syntax (1.0.0)

Anyone else have any of these problems?

- Jamie
Jamis B. (Guest)
on 2006-03-28 03:05
(Received via mailing list)
Sounds like you haven't installed the openssl module for Ruby. If you
do:

   ruby -ropenssl -e 'puts "worked"'

what happens?

- Jamis
Jamie M. (Guest)
on 2006-03-28 03:13
(Received via mailing list)
Thank you Jamis, just didn't click with me that openssl was a separate
lib that needed installing.

Working fine now.

- Jamie
This topic is locked and can not be replied to.