Forum: Ruby on Rails Can't quite get Rails working on Mac, help please :).

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Cooper M. (Guest)
on 2006-03-25 05:37
I've followed the install the install guide on
http://hivelogic.com/articles/2005/12/01/ruby_rail...
and it seemed to work. And I've been following the Instant Gratifiction
guide in Chapter four in Agile Web D. with Rails book. I'm in
terminal and I type -

cd work (everything works fine) then
rails demo (everything seems to work) then
cd demo (all goes well) then
ls -p (nothing wrong) then
ruby script server - and i get this error -

ruby: Is a directory - script (Errno::EISDIR)
william-mors-powerbook-g4-15:~/work/demo cooper$ ruby script/server
=> Booting lighttpd (use 'script/server webrick' to force WEBrick)
=> Rails application started on http://0.0.0.0:3000
=> Call with -d to detach (requires absolute paths in
config/lighttpd.conf)
=> Ctrl-C to shutdown server (see config/lighttpd.conf for options)
2006-03-24 21:50:10: (mod_fastcgi.c.1022) execve failed for:
public/dispatch.fcgi No such file or directory
2006-03-24 21:50:10: (mod_fastcgi.c.1048) the fastcgi-backend
public/dispatch.fcgi failed to start:
2006-03-24 21:50:10: (mod_fastcgi.c.1052) child exited with status 2
public/dispatch.fcgi
2006-03-24 21:50:10: (mod_fastcgi.c.1055) if you try do run PHP as
FastCGI backend make sure you use the FastCGI enabled version.
You can find out if it is the right one by executing 'php -v' and it
should display '(cgi-fcgi)' in the output, NOT (cgi) NOR (cli)
For more information check
http://www.lighttpd.net/documentation/fastcgi.html...
2006-03-24 21:50:10: (mod_fastcgi.c.1060) If this is PHP on Gentoo add
fastcgi to the USE flags
2006-03-24 21:50:10: (mod_fastcgi.c.1356) [ERROR]: spawning fcgi failed.
2006-03-24 21:50:10: (server.c.834) Configuration of plugins failed.
Going down.

Does anyone have any insight? Thanks! :)
Jack B. (Guest)
on 2006-03-25 05:46
(Received via mailing list)
On 3/24/06, Cooper M. <removed_email_address@domain.invalid> wrote:
> ruby script server - and i get this error -
>

Could this be due to a recent change in Lighttpd?

>From http://trac.lighttpd.net/trac/ticket/487 ...

--------------
in lighttpd 1.4.10 you will have CWD in your configfiles:

"bin-path" => CWD + "/public/dispatch.fcgi"

which will point to the current working dir. We had to change the
bin-path base dir to / for security reasons.
---------------

Adding the "CWD +" part fixed for me what looks like the same error.


--
Jack Baty
Fusionary Media - http://www.fusionary.com
Steven S. (Guest)
on 2006-03-25 05:49
(Received via mailing list)
Not sure about the second issue, but your first problem is caused
because the command should be "ruby script/server" not "ruby script
server".
Cooper M. (Guest)
on 2006-03-25 06:06
Steven S. wrote:
> Not sure about the second issue, but your first problem is caused
> because the command should be "ruby script/server" not "ruby script
> server".

Oops that was a typo, in my post, I did it right in terminal.
Steve L. (Guest)
on 2006-03-25 07:44
(Received via mailing list)
lighttpd after version 1.4.9 requires the full path in the "bin-path"
part
of the lighttpd.conf file.  So instead of:
  "bin-path" => "public/dispatch.fcgi",
You will need to do:
  "bin-path" => "/Users/USERNAME/demo/public/dispatch.fcgi",

-Steve
http://www.stevelongdo.com
This topic is locked and can not be replied to.