Forum: Ruby on Rails activerecord - mysql blobs...

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
barinek (Guest)
on 2006-03-21 20:53
I'm struggling with activerecord and mysql blobs (uploading files)...

blobs over 400K-ish cause the below exception...

ActiveRecord::StatementInvalid in File#upload

Mysql::Error: Lost connection to MySQL server during query:

I've tried blob, mediumblob, and longblob...

I'm using windows xp for development - and have not installed the mysql

simlar google postings/solutions have not worked

Yaroslav Markin (Guest)
on 2006-03-21 22:09
(Received via mailing list)
Suggestion to use file_column.. Sorry if you can't do this.. I'm pretty
sure any DB expert will say you storing blobs in database must suck.
Bamat Est (Guest)
on 2006-03-21 22:13
(Received via mailing list)
I'm fighting the exact same issue right now myself - so very
interested in seeing if someone comes back with an answer for it.

I did find some old posts here in the mailing list that suggest that
error has to do with some buggy mysql bindings in windows and pointed
to this page

i installed the dll bu haven't gotten it to work yet. Was also going
to try porting the code over to my linux webserver either tonight /
tommorow to see if the problem does go away once it's off of XP.
Bamat Est (Guest)
on 2006-03-22 23:22
(Received via mailing list)
Update - looks like I was able to solve my issue by merely increasing
the mysql max_allowed_packet parameter.

hopefully that'll solve yours too

Michael B. (Guest)
on 2006-03-23 17:06
very cool - that worked...

- Barinek
This topic is locked and can not be replied to.