Forum: Rails Engines WEBrick won't start after engines installation

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
JJ (Guest)
on 2006-03-21 19:03
I installed the engines and datebox_engine -plugins as advised in the
readme-files and everything went well. But now when I now try to start
the WEBrick server, it says "`const_missing': uninitialized constant
Engines (NameError)".

Any ideas how the Engines-constant could be initialized?



Complete trace:

$ruby script/server
=> Booting WEBrick...
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:200:in
`const_missing': uninitialized constant Engines (NameError)
        from
/usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:188:in
`load_environment'
        from
/usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:155:in
`load_environment'
        from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/core_ext/kernel.rb:27:in
`silence_warnings'
        from
/usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:152:in
`load_environment'
        from
/usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:81:in
`process'
        from
/usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:42:in
`run'
        from ./script/../config/../config/environment.rb:10
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
        from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:214:in
`require'
        from
/usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/servers/webrick.rb:52
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
        from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:214:in
`require'
        from
/usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/server.rb:28
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
        from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:214:in
`require'
        from script/server:3
romulus pasca (Guest)
on 2006-03-22 05:54
I have the same problem, please can
someone help us?
Leonardo S. (Guest)
on 2006-04-05 03:55
me too...
I'm using Substruct engine...
But I know one thing...
This occours only when we use the new version of ruby gems....
I uninstalled ruby and the gems and installed the old version of ruby
and ruby gems and it worked ok again...
But I need help too...
James A. (Guest)
on 2006-04-05 12:46
(Received via mailing list)
If you are trying to run Rails 1.1, please ensure that you have Ruby
1.8.4 installed. Next, remove ALL of your engines and the engines
plugin (just delete them). Then please run this:

 ruby script/plugin unsource
http://opensvn.csie.org/rails_engines/plugins/
 ruby script/plugin unsource
https://opensvn.csie.org/rails_engines/plugins/
 ruby script/plugin source http://svn.rails-engines.org/plugins/
 ruby script/plugin install engines -s
http://svn.rails-engines.org/plugins/

This is to ensure that your plugin command is installing from the
correct location. If you are still having problems, please reply,
remembering to include your versions of Ruby and Rails, and the
version of all your engines (found by running 'rake engines:info').

- james

On 4/5/06, Leonardo S. <removed_email_address@domain.invalid> wrote:
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> engine-users mailing list
> removed_email_address@domain.invalid
> http://lists.rails-engines.org/listinfo.cgi/engine...
>


--
* J *
  ~
This topic is locked and can not be replied to.