Forum: Ruby Cant install RMagick from gems

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Ryutaro Amano (Guest)
on 2006-03-18 01:49
(Received via mailing list)
I tried install Rmagick from gems, but didn't it.

ruby -v
ruby 1.8.4 (2005-12-24) [i386-mswin32]
gem -v
I have downloaded from

[c:\mytemp\RMagick-1.9.1-IM-6.2.3-win32]gem install RMagick-
Attempting local installation of 'RMagick-win32-1.9.2-mswin32.gem'
Successfully installed RMagick-win32, version 1.9.2
[c:\mytemp\RMagick-1.9.1-IM-6.2.3-win32]ruby postinstall.rb
RMagick 1.9.2 win32 Post Installation (see enclosed README for
license information)
detecting available fonts, writing to config/type-windows.xml...ok.
setting MAGICK_CONFIGURE_PATH to 'C:/ruby184/lib/ruby/gems/1.8/gems/
setting is only for current user.
Copying 5 dlls to C:/ruby184/bin...done.
all done.

ruby test.rb
[c:\myruby]ruby rmagick.rb
./RMagick.rb:4: uninitialized constant Magick (NameError)
         from C:/ruby184/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:21:in `require'
         from rmagick.rb:2

test.rb is
require 'rubygems'
require 'RMagick'

puts Magick::Long_version

I tried install progressbar using gems, the progressbar works well.
Why does'nt work RMagick ?
I need ImageMagick-6.2.4 dll ?

Ryutaro Amano
Kaspar S. (Guest)
on 2006-03-18 19:05
(Received via mailing list)

Can you repost this on the help forum in the RMagick project section on
rubyforge ? This is where Tim H. (the project's author) and I (your
humble windows packager) will definitly try to get you up and running.


Thank you.
This topic is locked and can not be replied to.