Forum: Ruby on Rails RE: problems with latest and greatest ?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Chris B. (Guest)
on 2006-03-16 23:03
(Received via mailing list)
I get the same error running Ruby 1.8.3 on Windows.



Chris


________________________________________
From: removed_email_address@domain.invalid
[mailto:removed_email_address@domain.invalid] On Behalf Of Dylan S.
Sent: Thursday, March 16, 2006 12:20 PM
To: removed_email_address@domain.invalid
Subject: [Rails] problems with latest and greatest ?

I just did the following:

1)  checked out latest rails from svn.
2)  built project using the /bin/rails with the latest rails binary.
3)  did a "rake freeze_edge" within the project

Now, script/server is failing
===========================
./script/../config/../vendor/rails/railties/lib/commands/../tasks/tmp.rake:1:
undefined method `namespace' for #<Object:0x401ce970> (NoMethodError)
        from
./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:142:in
`load'
        from
./script/../config/../vendor/rails/railties/lib/commands/server.rb:29
        from script/server:3
===========================

I am running Rake 0.7.0...
Any ideas ?
Dylan S. (Guest)
on 2006-03-16 23:12
(Received via mailing list)
Chris, are you running Rake 0.7.0 ?  Maybe do a "sudo gem update rake"
if
you're not.
Updating to the latest fixed one problem for me... but not these.

This sucks :)
This topic is locked and can not be replied to.