Forum: Ruby on Rails Webrick and Lighttpd

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Ron G. (Guest)
on 2006-03-12 08:07
I just went thru the hivelogic article to get everything installed on my
new mac. I then decided to run thru the ADC Rails article. In the
article it says to run 'script/server' which will start lighttpd if
installed or webrick if not. When I do it, I get webrick not lighttpd. I
followed the hivelogic article word for word and everything else seems
to be working fine. Is there something I need to do to the
lighttpd.config file to make this work? The ADC article makes it sound
like it should just work.

Tom M. (Guest)
on 2006-03-12 21:38
(Received via mailing list)
Make sure lighttpd is in your PATH.

 From the bash prompt:

which lighttpd

-- Tom M.
Ron G. (Guest)
on 2006-03-12 21:54
Tom M. wrote:
> Make sure lighttpd is in your PATH.
>  From the bash prompt:
> which lighttpd
> --
> -- Tom M.



That looks right to me.
Peter De Berdt (Guest)
on 2006-03-13 14:44
(Received via mailing list)
On 12 Mar 2006, at 20:54, Ron G. wrote:

> Returned:
> /usr/local/sbin/lighttpd
> That looks right to me.

Had the same problem and solved it this way:

1. Open the Terminal
2. Instead of "mate ~/.bash_login", type "sudo pico
~/.bash_login" (your file will show empty here, meaning the PATH
wasn't saved correctly last time around)
3. Copy/Paste the following lines:

export PATH="/usr/local/bin:/usr/local/sbin:$PATH"
export PATH="/usr/local/bin:/usr/local/sbin:/usr/local/mysql/bin:$PATH"

If you plan on installing RMagick, you'll probably want to add this
line too:

export PATH="/opt/local/bin:/opt/local/sbin:$PATH"

4. Type "Control-X" and save the file
5. You might need to chmod 777 the .bash_login file, I'm not sure
6. Open a new Terminal window and query "ruby --version" (it should
show "ruby 1.8.4 (2005-12-24) [powerpc-darwin8.5.0]")
7. Make a new rails application somewhere with "rails myappname"
8. cd myappname
9. script/server

It should now read:
=> Booting lighttpd (use 'script/server webrick' to force WEBrick)
=> Rails application started on
=> Call with -d to detach
=> Ctrl-C to shutdown server (see config/lighttpd.conf for options)

Best regards

Peter De Berdt
Ron G. (Guest)
on 2006-03-14 03:23
Thanks Peter, but that wasn't it. I opened .bash_login with pico and
both lines are there and typed correctly.
I did a control-x and tried script/server but it still started webrick.
Ron G. (Guest)
on 2006-03-14 06:01
Looks like I forgot to install FCGI.
This topic is locked and can not be replied to.