Forum: Ruby on Rails RMagick Instant Rails install problem

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Pete B. (Guest)
on 2006-03-08 02:07
Anyone help with this?

Am running Instant Rails on Win XP Sp2. Have downloaded the
RMagick-win32-1.9.2 files into c:\Instant-Rails-1.0\temp from the
rubyforge site.

Running "Gem install RMagick-win32-1.9.2-mswin32.gem"  from the temp
directory seems to work giving me a "Successfully installed
RMagick-win32, version 1.9.2" message.

However, when I then try and go

"ruby postinstall.rb" from the same directory I get

"postinstall.rb:1in 'require' : no such file to load --
postinstall/set_environment (LoadError)    from postinstall.rb:1"

I have no postinstall directory, should one have been corrected?

Thanks in advance.

Pete
kevin (Guest)
on 2006-03-08 04:42
I followed these instructions and it worked for me

http://rmagick.rubyforge.org/install-faq.html#win

Pete B. wrote:
> Anyone help with this?
>
> Am running Instant Rails on Win XP Sp2. Have downloaded the
> RMagick-win32-1.9.2 files into c:\Instant-Rails-1.0\temp from the
> rubyforge site.
>
> Running "Gem install RMagick-win32-1.9.2-mswin32.gem"  from the temp
> directory seems to work giving me a "Successfully installed
> RMagick-win32, version 1.9.2" message.
>
> However, when I then try and go
>
> "ruby postinstall.rb" from the same directory I get
>
> "postinstall.rb:1in 'require' : no such file to load --
> postinstall/set_environment (LoadError)    from postinstall.rb:1"
>
> I have no postinstall directory, should one have been corrected?
>
> Thanks in advance.
>
> Pete
Curt H. (Guest)
on 2006-03-08 07:25
(Received via mailing list)
On 3/7/06, Pete B. <removed_email_address@domain.invalid> wrote:
> However, when I then try and go
>
> "ruby postinstall.rb" from the same directory I get
>
> "postinstall.rb:1in 'require' : no such file to load --
> postinstall/set_environment (LoadError)    from postinstall.rb:1"
>
> I have no postinstall directory, should one have been corrected?

You have to make sure that the ruby\bin directory for the Ruby
included in Instant Rails is on your path before you run gem or
postinstall. The easiest way to ensure this is to open your Ruby
console window from Instant Rails using the menu item >>Rails
Applications>>Open Ruby Console Window"

Curt
Pete B. (Guest)
on 2006-03-08 12:35
> You have to make sure that the ruby\bin directory for the Ruby
> included in Instant Rails is on your path before you run gem or
> postinstall. The easiest way to ensure this is to open your Ruby
> console window from Instant Rails using the menu item >>Rails
> Applications>>Open Ruby Console Window"
>
> Curt

I was following the instructions on the RMagick website, and did in fact
run the commands from the Instant Rails R. Console Window.

Given that the "gem install..." command appeared to work, presumably the
path to Ruby is functional.

Any more ideas? I can now find RMagick under the
Instant-Rails\Ruby\lib\....\Gems\ directory, so it seems to have
installed itself there.

Cheers,

Pete
Curt H. (Guest)
on 2006-03-08 19:56
(Received via mailing list)
On 3/8/06, Pete B. <removed_email_address@domain.invalid> wrote:
> run the commands from the Instant Rails R. Console Window.
>
> Given that the "gem install..." command appeared to work, presumably the
> path to Ruby is functional.
>
> Any more ideas? I can now find RMagick under the
> Instant-Rails\Ruby\lib\....\Gems\ directory, so it seems to have
> installed itself there.

No more ideas from me (I haven't personally used RMagick). You'll need
to talk to the RMagick people.

Curt
This topic is locked and can not be replied to.