Forum: Ruby rubygems bug?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Logan C. (Guest)
on 2006-03-04 00:28
(Received via mailing list)
Help! Today I was trying to use rubygems and all of a sudden I
started getting the following odd
error messages:

% gem update
Upgrading installed gems...
ERROR:  While executing gem ... (NoMethodError)
     undefined method `name' for -517611318:Fixnum

% sudo gem update
Password:
Upgrading installed gems...
Updating Gem source index for: http://gems.rubyforge.org
ERROR:  While executing gem ... (ArgumentError)
     invalid date

% ruby -v
ruby 1.8.4 (2005-12-24) [powerpc-darwin8.4.0]

% gem --version
0.8.11

% uname -a
Darwin logan-capaldos.poly.edu 8.5.0 Darwin Kernel Version 8.5.0: Sun
Jan 22 10:38:46 PST 2006; root:xnu-792.6.61.obj~1/RELEASE_PPC Power
Macintosh powerpc
Dan Apostol (Guest)
on 2006-03-06 12:28
(Received via mailing list)
Hi!

I'm new in ruby/rails programming and i have a small problem.

I have installed InstantRails 1.0 (for Ruby/Rails/Mysql/Apache envs) and
I'm trying to make a small app working. I'm using auth_generator for
making a login page/users admin pages... and I have a problem when
trying to CHANGE the avatar for the user.

I have the following error:


  MissingSourceFile in Account#info

no such file to load -- GD

|RAILS_ROOT: ./script/../config/..|

Application Trace <#> | Framework Trace <#> | Full Trace <#>

|D:/work/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in 
`require__'
D:/work/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:214:in
`require'
#{RAILS_ROOT}/app/controllers/account_controller.rb:76:in `info'
#{RAILS_ROOT}/app/controllers/application.rb:14:in `process'
#{RAILS_ROOT}/app/controllers/application.rb:13:in `process'
-e:3|

|D:/work/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in 
`require__'
D:/work/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:214:in
`require'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/base.rb:853:in
`perform_action_without_filters'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/filters.rb:332:in
`perform_action_without_benchmark'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/benchmarking.rb:69:in
`perform_action_without_rescue'
D:/work/InstantRails/ruby/lib/ruby/1.8/benchmark.rb:293:in `measure'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/benchmarking.rb:69:in
`perform_action_without_rescue'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/rescue.rb:82:in
`perform_action'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/base.rb:369:in
`process_without_session_management_support'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/session_management.rb:116:in
`process'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/dispatcher.rb:38:in
`dispatch'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/webrick_server.rb:117:in
`handle_dispatch'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/webrick_server.rb:83:in
`service'
D:/work/InstantRails/ruby/lib/ruby/1.8/webrick/httpserver.rb:104:in
`service'
D:/work/InstantRails/ruby/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'
D:/work/InstantRails/ruby/lib/ruby/1.8/webrick/server.rb:173:in
`start_thread'
D:/work/InstantRails/ruby/lib/ruby/1.8/webrick/server.rb:162:in
`start_thread'
D:/work/InstantRails/ruby/lib/ruby/1.8/webrick/server.rb:95:in `start'
D:/work/InstantRails/ruby/lib/ruby/1.8/webrick/server.rb:92:in `start'
D:/work/InstantRails/ruby/lib/ruby/1.8/webrick/server.rb:23:in `start'
D:/work/InstantRails/ruby/lib/ruby/1.8/webrick/server.rb:82:in `start'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/webrick_server.rb:69:in
`dispatch'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/servers/webrick.rb:59
D:/work/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:214:in
`require'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/server.rb:28
D:/work/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:214:in
`require'
./script/server:3|

|D:/work/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in 
`require__'
D:/work/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:214:in
`require'
#{RAILS_ROOT}/app/controllers/account_controller.rb:76:in `info'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/base.rb:853:in
`perform_action_without_filters'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/filters.rb:332:in
`perform_action_without_benchmark'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/benchmarking.rb:69:in
`perform_action_without_rescue'
D:/work/InstantRails/ruby/lib/ruby/1.8/benchmark.rb:293:in `measure'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/benchmarking.rb:69:in
`perform_action_without_rescue'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/rescue.rb:82:in
`perform_action'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/base.rb:369:in
`process_without_session_management_support'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/session_management.rb:116:in
`process'
#{RAILS_ROOT}/app/controllers/application.rb:14:in `process'
#{RAILS_ROOT}/app/controllers/application.rb:13:in `process'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/dispatcher.rb:38:in
`dispatch'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/webrick_server.rb:117:in
`handle_dispatch'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/webrick_server.rb:83:in
`service'
D:/work/InstantRails/ruby/lib/ruby/1.8/webrick/httpserver.rb:104:in
`service'
D:/work/InstantRails/ruby/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'
D:/work/InstantRails/ruby/lib/ruby/1.8/webrick/server.rb:173:in
`start_thread'
D:/work/InstantRails/ruby/lib/ruby/1.8/webrick/server.rb:162:in
`start_thread'
D:/work/InstantRails/ruby/lib/ruby/1.8/webrick/server.rb:95:in `start'
D:/work/InstantRails/ruby/lib/ruby/1.8/webrick/server.rb:92:in `start'
D:/work/InstantRails/ruby/lib/ruby/1.8/webrick/server.rb:23:in `start'
D:/work/InstantRails/ruby/lib/ruby/1.8/webrick/server.rb:82:in `start'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/webrick_server.rb:69:in
`dispatch'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/servers/webrick.rb:59
D:/work/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:214:in
`require'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/server.rb:28
D:/work/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
D:/work/InstantRails/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:214:in
`require'
./script/server:3
-e:3|

|This error occured while loading the following files:
   GD|


    Request

*Parameters*: {"post"=>{"lastname"=>"aaaaa", "firstname"=>"bbbbbb",
"picture"=>#<StringIO:0x395e3f8>, "password"=>"",
"newemail"=>"removed_email_address@domain.invalid", "passwordbis"=>""}}



it is related with GD module (I guess).. so, i've downloaded ruby-gd
from http://raa.ruby-lang.org/cache/ruby-gd/ruby-GD-0.7... and
unzipped it into [instantRails_path]/ruby folder. And I still get that
error.

Do I need to configure/download/install something mode?

TIA

Daniel.
Jim W. (Guest)
on 2006-03-06 12:45
Logan C. wrote:
> Help! Today I was trying to use rubygems and all of a sudden I
> started getting the following odd
> error messages:
>
> % gem update
> Upgrading installed gems...
> ERROR:  While executing gem ... (NoMethodError)
>      undefined method `name' for -517611318:Fixnum
>
> % sudo gem update
> Password:
> Upgrading installed gems...
> Updating Gem source index for: http://gems.rubyforge.org
> ERROR:  While executing gem ... (ArgumentError)
>      invalid date

Is it only the update command that is having problems?  Could you try
running it with the --backtrace option to help pinpoint the trouble
code.

Thanks.

--
-- Jim W.
Ben Allen (Guest)
on 2006-03-06 19:46
(Received via mailing list)
Try installing GD as a RubyGem.  From the command line, run 'gem install
gd2
--remote'  That will download the GD2 libraries for Ruby and
auto-install
them in their correct place.  I have had problems with attempting to
manually install libraries, and installing them as a RubyGem has worked
every time. (I'm assuming that GD and GD2 aren't completely unrelated
libraries with frustratingly similar names)
Dan Apostol (Guest)
on 2006-03-07 10:08
(Received via mailing list)
thanks, but it didn't work. The same message :(

Cheers.

Dan.
Dan Apostol (Guest)
on 2006-03-07 15:15
(Received via mailing list)
No one? :) pls.. hlp! :)
Dan Apostol (Guest)
on 2006-03-08 16:06
(Received via mailing list)
No one? :)

Pls...

Thanks.
unknown (Guest)
on 2006-03-08 18:05
(Received via mailing list)
You might try copying gd into your vendor directory.  If your require
command says something like "require 'something/gd'", then you'll need
gd.rb in vendor/something.

Also, you'll usually get better answers to RoR questions on the Rails
mailing list.  http://lists.rubyonrails.org/mailman/listinfo/rails

Jim
Dan Apostol (Guest)
on 2006-03-08 18:15
(Received via mailing list)
Thank you very much ;)

Regards,

Daniel.
This topic is locked and can not be replied to.