Forum: Ruby on Rails error Before updating scaffolding?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Mike (Guest)
on 2006-02-26 02:13
(Received via mailing list)
Hello all, I am a bit hung up.

I have created a simple table (pluralized) named aircrews and I have
edited
my database.yml file to point to the database that I created and that is
holding the table aircrews.

I have gone through the depot tutorial in the Agile book and when I have
run
the scaffolding command for the depot app all has worked fine for the
table
products.

Now when I run the ruby script/generate scaffold Aircrew Admin

I get the following message:

error Before updating scaffolding from new DB schema, try creating a
table
for your model (Aircrew)

The database and the plural name of the table exists but I cannot run
the
scaffold command. It works ok on the Agile depot application but does
not
work when I color outside of the lines.

Does anyone have any ideas on where I should look?

Thank you!
This topic is locked and can not be replied to.