Forum: Rails Engines After installing engines and datebox_engine server can't be

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Human D. (Guest)
on 2006-02-21 21:57
(Received via mailing list)
Hello,
I have a problem that's strange to me, I installed engines and
datebox_engine using the following command, but now I can't start the
server
(I didn't changed any file).
ruby script\plugin install engines
ruby script\plugin install datebox_engine

I'm using rails edge.

When I try to run the server (WEBrick) is gives me the following error:

./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:92:in
`as_load_path': stack level too
deep (SystemStackError)
        from
./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:106:in
`const_missing'
        from
./script/../config/../vendor/plugins/engines/lib/dependencies_extensions.rb:28:in
`require_or_load'
        from
./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:30:in
`depend_on'
        from
./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:74:in
`require_dependency
'
        from
./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:74:in
`require_dependency
'
        from
./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:108:in
`const_missing'
        from
./script/../config/../vendor/plugins/engines/lib/dependencies_extensions.rb:28:in
`require_or_load'
        from
./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:30:in
`depend_on'
         ... 874 levels...
        from
./script/../config/../vendor/rails/railties/lib/commands/server.rb:28
        from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in
`require__'
        from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in
`require'
        from script/server:3
James A. (Guest)
on 2006-02-22 01:41
(Received via mailing list)
I'd guess you are using Edge Rails - you need to check out an SVN
version of the engines plugin, from:

  http://opensvn.csie.org/rails_engines/engines/trunk

You need to follow the instructions here:
http://www.ruby-forum.com/topic/54572

- james

On 2/21/06, Human D. <removed_email_address@domain.invalid> wrote:
>
> 
./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:30:in
> 
./script/../config/../vendor/rails/activesupport/lib/active_support/dependencies.rb:108:in
>         from
>
>
>


--
* J *
  ~
This topic is locked and can not be replied to.