Forum: Ruby Facets units not working

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
David V. (Guest)
on 2006-02-19 21:25
(Received via mailing list)
I tried to give Units a try to find out the date difference between two
days,
and ran into this:

irb(main):001:0> require 'facet/units'
Errno::ENOENT: No such file or directory
- /usr/share/calibre/units/standard.yaml
        from /usr/lib/ruby/1.8/yaml.rb:129:in `initialize'
        from /usr/lib/ruby/1.8/yaml.rb:129:in `load_file'

from
/usr/lib/ruby/gems/1.8/gems/facets-1.0.3/packages/more/lib/facet/units.rb:804
        from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
        from (irb):1

Is there something I'm missing? Or is this a genuine facets / packaging
bug?

I'm using (well, trying to use) the 1.0.3 gem version of Facets.

David V.
Trans (Guest)
on 2006-02-20 01:33
(Received via mailing list)
Thanks for reporting this.  I will look at tonight and get back to you.

T.
Trans (Guest)
on 2006-02-20 02:00
(Received via mailing list)
Well, I have to recommend that Facets be installed via the tar.bz2
using setup.rb, instead of using Gems.

Unfortunately I had forgotten about this, but AFAIK, Gems has no
support for installing configuration and shared data files. So I'm not
sure how I'm going to resolve this conflict between Gems and setup.rb
:-(

T.
This topic is locked and can not be replied to.