Forum: Ruby on Rails file_column generating random empty images

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Nic W. (Guest)
on 2006-02-17 08:49
(Received via mailing list)
Hi all,
 I emailed Sebastian awhile back about this, but I know he is busy,
so I'm asking for your help.

I'm using the latest version of file_column from SVN, or the non-SVN
version (doesn't matter),
but on some files, file_column will create  0kb files.

The tmp directory will contain the correct file size, and I copied the
temp over the 0kb file, and then it displayed.

I've followed the threads ('file_column on windows?') about the 'file
-bi' problem, and I installed the GNUWin32 version of file, but the
same problem still exists.

I tried Sebastians idea from the same thread about replacing
get_content_type with another piece of code, but that didn't work....

Can anyone help me with this? The server logs don't show anything after
I installed File, so this is hard to troubleshoot.

Here are the two images:
http://www.billigdrucker.de/images/hardware/drucke...
http://images.lexmark.com/vgn/files/portal/X2250_big.jpg
The Dell image
works, but not the Lexmark one.

My Edit page looks like this:

<%= file_column_field "device", "image" %>

And my Model has this:

file_column     :image

--
- Nic
This topic is locked and can not be replied to.