Forum: Ruby on Rails Upgrading to Ruby 1.8.4 and strange problems!

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Human D. (Guest)
on 2006-02-11 23:54
(Received via mailing list)
Hi folks,
There is a strange problem here, I've installed the latest version of
One-Click Ruby installer [1.8.4-16 preview3], everything went fine, and
after that I've installed Rails 1.0.

No problem in setup process, but now, when I try run my rails
application,
there are many strange things happening.

In one my application no CSS apply, looks like there is no CSS file, and
worst in another application, I get the following error from the layout
rhtml file.

parse error, unexpected $, expecting kEND

What's changed in this version? Or Do I forget to install a gem orâ?¦?

Thanks in advance
-    H
Human D. (Guest)
on 2006-02-12 00:24
(Received via mailing list)
Hi folks,
There is a strange problem here, I've installed the latest version of
One-Click Ruby installer [1.8.4-16 preview3], everything went fine, and
after that I've installed Rails 1.0.

No problem in setup process, but now, when I try run my rails
application,
there are many strange things happening.

In one my application no CSS apply, looks like there is no CSS file, and
worst in another application, I get the following error from the layout
rhtml file.

parse error, unexpected $, expecting kEND

What's changed in this version? Or Do I forget to install a gem orâ?¦?

Thanks in advance
-    H
eliazar (Guest)
on 2006-02-17 06:22
(Received via mailing list)
Human D. <h.dunnil@...> writes:
>
> Hi folks,There is a strange problem here, I've installed the latest version of
One-Click Ruby installer [1.8.4-16 preview3], everything went fine, and
after
that I've installed Rails 1.0.No problem in setup process, but now, when
I try
run my rails application, there are many strange things happening.
> In one my application no CSS apply, looks like there is no CSS file, and worst
in another application, I get the following error from the layout rhtml
file.parse error, unexpected $, expecting kEND
> What's changed in this version? Or Do I forget to install a gem orâ?¦?Thanks in
advance-    H

I also installed the One-Click Ruby installer [1.8.4-16 preview3]
followed by
Rails 1.0, and had the exact same problem that you're having: a nasty
"unexpected $, expecting kEND" error that just woulnd't go away no
matter what I
did to my rails app.

Just a few minutes ago, I installed the One-Click Ruby installer
[1.8.2-15
Stable Release] and to much rejoicing on my part the problem went
magically away.

-eliazar
Scott Claerhout (Guest)
on 2006-02-22 00:49
I was having the same problem.  Reverted from windows one-click
installer '1.8.4-16 preview3' to '1.8.2-15 Stable Release' and
everything works fine. Thanks for posting your fix to this problem, was
a great help.

-Scott
Curt H. (Guest)
on 2006-02-22 16:31
(Received via mailing list)
Can either you or eliazar send me Ruby code which has this problem. I
would like to figure what is causing this and fix it (if its something
I have the power to fix).

Curt
James A. (Guest)
on 2006-02-23 00:17
(Received via mailing list)
My impression of 1.8.4 is that it's MUCH more strict about the use
(i.e. lack of) parenthesis in method calls. You might want to try
wrapping any method parameters in parenthesis at the offending line,
if you can spot any...

- james

On 2/22/06, Curt H. <removed_email_address@domain.invalid> wrote:
> > a great help.
> _______________________________________________
> Rails mailing list
> removed_email_address@domain.invalid
> http://lists.rubyonrails.org/mailman/listinfo/rails
>


--
* J *
  ~
Dillone W. (Guest)
on 2006-02-25 18:34
I met exactly the same problem today.

It should be caused by one click 1.8.4 preview 3.

I changed back to one click 1.8.2-15 stable, everything turns out to be
wonderful, not strange errors at all.

So, I think there still some work to do with one click 1.8.4, we'd
better do not use preview 3.

Cheers
Sorenson (Guest)
on 2006-02-26 00:05
I have been having the exact same problem since upgrading to
InstantRails 1.0 on my windows laptop, which includes ruby 1.8.4.  It's
a very frustrating error!  The parser complains of a line in my standard
layout file.  However, the layout works fine for certain views but
produces the error for others.  I can make the error go away simply by
changing Class1 to Class2 or Class3 in the view rhtml code, but Class4
in the view will cause the same error.

<% for x in Class1.find(:all) %>
	<%= x.name %><br>
<% end %>

Again, the error is reported to be in the layout, even though the exact
same layout works fine in most views.  I'm going to try going back to
earlier ruby 1.8.2 while keeping the same rails.
Sorenson (Guest)
on 2006-02-26 04:35
Using ruby 1.8.2 from the 12/24/2005 Instant rails release seems to fix
the problem in InstantRails 1.0
Raju Gautam (Guest)
on 2006-10-29 11:25
Sorenson wrote:
> Using ruby 1.8.2 from the 12/24/2005 Instant rails release seems to fix
> the problem in InstantRails 1.0

It was saying "unexpected $, expecting kEND" before but when i download
the InstantRails 1.0 as you said and run the script it says only "syntax
error" whereas there is no such error i found on the script.

What may be the cause of error? Please help.

rajug
This topic is locked and can not be replied to.