Forum: Ruby on Rails acts_as_taggable Produces Bad SQL - Find Fails

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
HH (Guest)
on 2006-02-10 00:56
(Received via mailing list)
I am using acts_as_taggable in my application and on the tagging side of
things, no problem at all. Running edge Rails and PostgreSQL 8.1.

I am then trying to find all my AR objects with a certain tag. The tag
is:
lasvegas and I know that there are at least 3 records with that tag.

So, I'm doing this:

@lists = List.find_tagged_with :any => @search_string, :separator => '+'

The problem is that the SQL generated looks like this:

SELECT lists.* FROM lists, tags, taggings WHERE lists.id =
taggings.taggable_id AND taggings.taggable_type = 'List' AND
taggings.tag_id
= tags.id AND tags.name IN ('anylasvegas', 'separator+')

See what's right after the IN clause? It says 'anylasvegas' - why? BTW,
using 'lasvegas' returns the correct results.

I used the :any symbol in the finder per the instructions and all the
permutations I tried to get rid of it just gave me syntax errors, etc...

So, am I doing something wrong or what?

Thanks,
HH
San (Guest)
on 2006-02-10 01:01
(Received via mailing list)
This patch might help:

http://rubyforge.org/tracker/index.php?func=detail...

Cheers,

-San
HH (Guest)
on 2006-02-10 02:27
(Received via mailing list)
Excellent, I'll give this a go, thanks.

Anyone know the best way to install this patch?

I tried simply commenting out the old method in the plugin and inserting
this but I get this exception:

undefined method `split_tag_names' for
ActiveRecord::Acts::Taggable:Module

Indeed, looking at the plug-in I don't see that method defined
anywhere...

What gives?

Thanks,
Hunter
Kenneth L. (Guest)
on 2006-02-10 23:31
(Received via mailing list)
yeah, i'm having problems, too. i get an error with a later function
in the gem. any help would be appreciated.
This topic is locked and can not be replied to.