Forum: Ruby on Rails Ferret on Rails -- Webrick won't start?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
softwareengineer 99 (Guest)
on 2006-02-07 02:30
(Received via mailing list)
Hello,
  I tried using
  http://ferret.davebalmain.com/trac/wiki/FerretOnRails
  but Webrick won't start after implementing the plugin?

  I tried both versions but to no avail?
  All I get is Booting up ... and then it dies?

  No info in log/development.log?

  Does anyone has a working copy of acts_as_ferret or has any ideas on
what's wrong? I am placing the plugins in
vendor/plugins/acts_as_ferret directory.

  Thanks
  Frank
Jebus (Guest)
on 2006-02-07 04:54
(Received via mailing list)
I had the same problem when I was trying this. Make sure you have the
required files in the right spot.

{RAILS_ROOT}/vendor/plugins/acts_as_ferret/init.rb
{RAILS_ROOT}/vendor/plugins/acts_as_ferret/lib/acts_as_ferret.rb
                                                                   ^--
notice the lib directory
Albert R. (Guest)
on 2006-02-07 12:18
(Received via mailing list)
You need the ferret gem, have you installed that?
Also, the implementation, when I tried to use it, was somewhat broken. I
have posted an example of working code here:

http://albert.delamednoll.se/articles/2005/12/20/t...

And as the title says, there is simple unicode token support there too,
and you can rather simply extend that to include whatever characters you
need to index.

Albert
softwareengineer 99 (Guest)
on 2006-02-07 18:26
(Received via mailing list)
Thanks,
  Yes, I have Ferret installed (and working but not with acts_as_*)

  I will check out the code you posted and try with it.

  Thanks
  Frank

Albert R. <removed_email_address@domain.invalid> wrote:  You need the ferret 
gem, have you
installed that?
Also, the implementation, when I tried to use it, was somewhat broken. I
have posted an example of working code here:

http://albert.delamednoll.se/articles/2005/12/20/t...

And as the title says, there is simple unicode token support there too,
and you can rather simply extend that to include whatever characters you
need to index.

Albert
softwareengineer 99 (Guest)
on 2006-02-07 18:26
(Received via mailing list)
Hi Jebus,
  I think this may be the issue.

  Thank you very much for your reply.
  Frank

Jebus <removed_email_address@domain.invalid> wrote:  I had the same problem when 
I was
trying this. Make sure you have the
required files in the right spot.

{RAILS_ROOT}/vendor/plugins/acts_as_ferret/init.rb
{RAILS_ROOT}/vendor/plugins/acts_as_ferret/lib/acts_as_ferret.rb
                                                                   ^--
notice the lib directory
This topic is locked and can not be replied to.