Forum: Ruby on Rails [GLOBALIZE] Trouble getting example on wiki working

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Saimon M. (Guest)
on 2006-02-05 19:24
Hi,

I decided to integrate globalize into my app yesterday but I've run into
trouble.

I originally decided to try a db translation on one of my models so I
followed the  wiki example and modified where appropriate.

When I tried to create an empty Album via the console I get the
following error:

http://www.rafb.net/paste/results/opZ13I27.html

I tried to investigate and from what I found the problem seems to stem
from the fact that globalize overrides the validations mechanism.

To cut a long story short as my app is running edge rails I decided to
create a new test rails app (using rails 1.0) and follow the globalize
wiki example exactly.

I get the following failure:

http://www.rafb.net/paste/results/L617lh70.html

I then decied to run the test_plugins rake task. I also get a failure
for that:

http://www.rafb.net/paste/results/c5AWAo37.html


I'd really appreciate it of someone could help me out here. I really
need to get i18n in asap.

Environment details:
saimon@iris ~/dev/workspace/sandbox $ ruby --version
ruby 1.8.3 (2005-09-21) [i686-linux]

I'd also like to see a full example app I can download and test. Any
open source apps using globalize?

Many thanks,

Saimon
This topic is locked and can not be replied to.