Forum: Ruby on Rails Apache 2.2 don't work with fastcgi

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Andrea R. (Guest)
on 2006-02-01 18:09
I'm trying to install mod_fastcgi for my rails app.

I use Apache 2.2 and FastCGI 2.4.2 in windows xp.
I have modified the httpd.conf adding LoadModule fastcgi_module
modules/mod_fastcgi.dll (with mod_fastcgi.dll and mod_fastcgi.so in the
modules directory).

Whe i try to start Apache i have this error
----------------------------
apache: Syntax error on line 122 of C:/xampp/apache/conf/httpd.conf:
Cannot load C:/xampp/apache/modules/mod_fastcgi.dll into server:
Impossible to find the module.
----------------------------
But the file is in the dir modules. So Apache not start becouse don't
load fastcgi.

Then I have find in the web this link
http://groups.google.it/group/mailing.freebsd.port......
but I have not understand the solution. Then it ask for unix.

Thanks to all for your time.
--Reis.

Thi message starts from Google G.
http://groups.google.it/group/comp.lang.ruby/brows...
Mathieu C. (Guest)
on 2006-02-01 18:30
(Received via mailing list)
AFIK FastCgi and Ruby stuffs related are not ready for 2.2.

Try using Apache 2.0.55 and feel smooth with

http://rubyforge.org/projects/rubyforapache
Andrea R. (Guest)
on 2006-02-01 18:33
Mathieu C. wrote:
> AFIK FastCgi and Ruby stuffs related are not ready for 2.2.
>
> Try using Apache 2.0.55 and feel smooth with
>
> http://rubyforge.org/projects/rubyforapache

Thanks so much.
--Reis
Charles M. Gerungan (Guest)
on 2006-02-01 18:54
(Received via mailing list)
On 1-feb-2006, at 17:09, Andrea R. wrote:

> I use Apache 2.2 and FastCGI 2.4.2 in windows xp.

There is a patch somewhere out there for FastCGI and Apache 2.2.
Either hunt for that or use Mathieu's suggestion.

--
Regards, Charles.
Kim S. (Guest)
on 2006-02-01 20:01
(Received via mailing list)
On Feb 1, 2006, at 9:28 AM, Mathieu C. wrote:

> AFIK FastCgi and Ruby stuffs related are not ready for 2.2.
>
> Try using Apache 2.0.55 and feel smooth with
>
> http://rubyforge.org/projects/rubyforapache

I have patched mod_scgi for Apache 2.2 and Rails runs fine with it.
I think that if you get mod_fastcgi properly patched, you should have
no problem with Rails.

Kim
--
  Kim S. - principal, Shrier and Deihl - 
mailto:removed_email_address@domain.invalid
Remote Unix Network Admin, Security, Internet Software Development
   Tinker Internet Services - Superior FreeBSD-based Web Hosting
                      http://www.tinker.com/
Kevin (Guest)
on 2006-02-01 20:28
(Received via mailing list)
Official scgi 1.10 is just out which fixed Apache 2.2 compilation issue.

Kevin
This topic is locked and can not be replied to.