Forum: Ruby on Rails Can't install rails, instructions in the book are wrong....

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Greg (Guest)
on 2006-01-25 00:07
I can't even get Rails installed in Windows XP.
I follow the directions in "Agile Web D. With Rails", I
download Ruby, then RubyGems, and I install those, and I then type the
command that came right out of the book.

C:\ruby>gem install rails --include-dependencies

and it doesn't even work:

C:\ruby>"C:\ruby\bin\ruby.exe" "C:\ruby\bin\gem" install rails
--include-dependencies
ERROR:  While executing gem ... (OptionParser::InvalidOption)
    invalid option: --include-dependencies

Hard to believe.  Did I do something wrong?

Greg
Chris Lamb (Guest)
on 2006-01-25 00:24
(Received via mailing list)
I am not sure the correct option to automatically accept the
dependencies. However, I have installed it a few times and there were
only 5 prompts, in quick succession, to say "y" to.

If you want to get it installed, skip the "--include-dependencies"
option and just accept the dependencies when prompted.

Chris

On 24/01/06, Greg <removed_email_address@domain.invalid> wrote:
> --include-dependencies
> _______________________________________________
> Rails mailing list
> removed_email_address@domain.invalid
> http://lists.rubyonrails.org/mailman/listinfo/rails
>


--
Chris Lamb
Greg (Guest)
on 2006-01-25 00:34
Sorry, Chris.  I didn't even mention that the next thing I tried was
what you suggested, and this is what I got:

gem install rails
Attempting local installation of 'rails'
 -> Local installation can't proceed due to LoadError:
Could not find RubyGem activesupport (= 1.2.5)
Attempting remote installation of 'rails'
Successfully installed rails_analyzer_tools, version 1.1.0
Installing RDoc documentation for rails_analyzer_tools-1.1.0...

Seems to have worked, right?  But I thought I would then find a
"rails.exe" file, since the book clearly states that "rails" is a
command.  I found no such file, and so it's very hard for me to tell if
I am wrong, or if the installation stuff just isn't working.

Greg

Chris Lamb wrote:
> I am not sure the correct option to automatically accept the
> dependencies. However, I have installed it a few times and there were
> only 5 prompts, in quick succession, to say "y" to.
>
> If you want to get it installed, skip the "--include-dependencies"
> option and just accept the dependencies when prompted.
>
> Chris
>
> On 24/01/06, Greg <removed_email_address@domain.invalid> wrote:
>> --include-dependencies
>> _______________________________________________
>> Rails mailing list
>> removed_email_address@domain.invalid
>> http://lists.rubyonrails.org/mailman/listinfo/rails
>>
>
>
> --
> Chris Lamb
Kevin O. (Guest)
on 2006-01-25 01:53
Greg wrote:
>> If you want to get it installed, skip the "--include-dependencies"
>> option and just accept the dependencies when prompted.
>>

Save yourself some hassle and go download InstantRails 1.0.

http://instantrails.rubyforge.org/wiki/wiki.pl
David R. (Guest)
on 2006-01-25 02:06
(Received via mailing list)
On Jan 24, 2006, at 4:53 PM, Kevin O. wrote:

> Save yourself some hassle and go download InstantRails 1.0.

Or go buy a Mac. :-)

Ha, ha. Just kidding. Sort of.

About the Rails executable -- mine is in c:\ruby\bin\, named
rails.cmd. Your %PATH% should include c:\ruby\bin\ (or its equivalent
on your machine) in order to get this to work as the book describes.

Hope this helps,
David
Andrew S. (Guest)
on 2006-01-25 02:12
(Received via mailing list)
>
>
> C:\ruby>gem install rails --include-dependencies



gem install rails -y

if you type:  gem help install
you will see a list of options
Ben M. (Guest)
on 2006-01-25 02:43
(Received via mailing list)
Greg wrote:
> --include-dependencies
> ERROR:  While executing gem ... (OptionParser::InvalidOption)
>     invalid option: --include-dependencies
>
> Hard to believe.  Did I do something wrong?
>
> Greg
>
>

I just had this problem yesterday... resolved it by updating rubygems!
The version I had didn't understand the
"include-dependencies" option.

I also discovered yesterday that I've had rails 0.10.0 for a while and
didn't know it because gem was considering that
later than 1.0!! Someone suggested specifying the rails version number
as a gem option but I don't remember the exact
syntax. Ben Rubenstien, I think that was you, right?

b
Ben R. (Guest)
on 2006-01-25 02:55
(Received via mailing list)
> I also discovered yesterday that I've had rails 0.10.0 for a while and
> didn't know it because gem was considering that
> later than 1.0!! Someone suggested specifying the rails version number as
> a gem option but I don't remember the exact
> syntax. Ben Rubenstien, I think that was you, right?
>

Wow ~ Riding the 0.10.0 ~ !  No, that wasn't me :(... My guess though is
that the problem here is with the gems install(?).  Might try running
gem
--version to insure it is the latest version.  I would also insure the
ruby
-v produces 1.8.4.  Also check the PATH variable to ensure that ruby is
in
it...

~ Ben
Ezra Z. (Guest)
on 2006-01-25 03:10
(Received via mailing list)
The syntax is:

gem install rails --version=1.0.0

And if your gem command does not support the --include-dependencies
option it means your gem command is old so upgrad it!:

gem update --system

Cheers-
-Ezra


On Jan 24, 2006, at 4:55 PM, Ben R. wrote:

> would also insure the ruby -v produces 1.8.4.  Also check the PATH
> >
> >
> later than 1.0!! Someone suggested specifying the rails version
>
> --
> Ben R.
> http://www.benr75.com
> _______________________________________________
> Rails mailing list
> removed_email_address@domain.invalid
> http://lists.rubyonrails.org/mailman/listinfo/rails

-Ezra Z.
Yakima Herald-Republic
WebMaster
http://yakimaherald.com
509-577-7732
removed_email_address@domain.invalid
Ben M. (Guest)
on 2006-01-25 03:58
(Received via mailing list)
Oh... sorry... Ezra not Ben... two names I see a lot here. :-)

thanks you guys and keep it up! :-D

b
Greg (Guest)
on 2006-01-25 05:56
Thanks to everyone for your e-mails.  The book seems to mistakenly
believe that all that is required is 1.8.2 and that's not quite true.
What threw me off was believing that statement, so I downloaded
ruby182-14.exe, which was built on
2005-01-01, and unfortunately the "gem" there wasn't compatible with the
instructions in the book.  "gem update rails --include-dependencies"
gave the syntax error that I previously mentioned.  That led me down all
kinds of bad trails.  Tonight I went back to
http://rubyforge.org/frs/?group_id=167 and installed ruby182-15.exe,
which was built 2005-04-20, and this has a "gem" that supports the
syntax mentioned in the book.

I just have one more set of questions: Since building Windows one-click
installations seems to lag far behind the UNIX builds, could someone
please tell me if I ever have to again even worry about this?

What I mean is: Now that I have ruby, gem, and rails, is there now one
"gem update ..." command that I can use that will update _everything_,
even ruby?

Right now I still have ruby 1.8.2.  I have done "gem update --system",
as one of you suggested.  gem -v now gives me 0.8.11, but I don't know
if that's the latest or not.  Finally, I noticed that it installed
rails-1.0.0, and I assume that that is the latest.

I tried to upgrade ruby itself via "gem update ruby", but that just gave
me errors.

Now that I have a "stable" system, I am reluctant to try to unzip some
new Ruby zipfile into a directory that I originally created via a
Windows one-click install, but maybe they have separated things cleanly
enough that that won't hurt anything.

Is it completely safe to update ruby by simply grabbing the latest
zipfile and extracting into my ruby directory?

Thanks again.

Greg





Ezra Z. wrote:
> The syntax is:
>
> gem install rails --version=1.0.0
>
> And if your gem command does not support the --include-dependencies
> option it means your gem command is old so upgrad it!:
>
> gem update --system
>
> Cheers-
> -Ezra
>
>
> On Jan 24, 2006, at 4:55 PM, Ben R. wrote:
>
>> would also insure the ruby -v produces 1.8.4.  Also check the PATH
>> >
>> >
>> later than 1.0!! Someone suggested specifying the rails version
>>
>> --
>> Ben R.
>> http://www.benr75.com
>> _______________________________________________
>> Rails mailing list
>> removed_email_address@domain.invalid
>> http://lists.rubyonrails.org/mailman/listinfo/rails
>
> -Ezra Z.
> Yakima Herald-Republic
> WebMaster
> http://yakimaherald.com
> 509-577-7732
> removed_email_address@domain.invalid
Kevin O. (Guest)
on 2006-01-25 06:06
Greg wrote:
>
> I just have one more set of questions: Since building Windows one-click
> installations seems to lag far behind the UNIX builds, could someone
> please tell me if I ever have to again even worry about this?
>

Not quite sure what you mean by this... you can use instantrails to
install it all right now, and it even has ruby 1.8.4.

http://instantrails.rubyforge.org/wiki/wiki.pl

Once you have that all installed you can use the gem system to update
rails as usual.

_Kevin
Curt H. (Guest)
on 2006-01-25 06:08
(Received via mailing list)
You've got an old version of RubyGems. I missed the beginning of this
thread, but if you're on Windows you should get the latest version of
the one-click installer (182-15) as it comes with a newer version of
RubyGems. Otherwise, download the new version of RubyGems from
RubyForge and install it and your problem should be fixed.

Curt
Ezra Z. (Guest)
on 2006-01-25 06:56
(Received via mailing list)
Greg-

	You now have the latest version of gem 0.8.11 . Gems is only a
package manger for software written in ruby and not for ruby itslef.
You cannot update the ruby binary through gems. But many people are
using ruby 1.8.2 still to do rails work, myself included. ANd
rails1.0.0 is also the latest stable release.

	In order to keep your riuibygems up to date you can run this command:
gem update --system

in order to keep all your ruby packages installed via gem you can run:
gem update

	You should have a nice stable set up now that won't need to change
until you decide to move to ruby1.8.4

Cheers-
-Ezra

On Jan 24, 2006, at 7:56 PM, Greg wrote:

> http://rubyforge.org/frs/?group_id=167 and installed ruby182-15.exe,
> even ruby?
> Now that I have a "stable" system, I am reluctant to try to unzip some
> Greg
>> And if your gem command does not support the --include-dependencies
>>> would also insure the ruby -v produces 1.8.4.  Also check the PATH
>>> http://lists.rubyonrails.org/mailman/listinfo/rails
>
> _______________________________________________
> Rails mailing list
> removed_email_address@domain.invalid
> http://lists.rubyonrails.org/mailman/listinfo/rails
>

-Ezra Z.
WebMaster
Yakima Herald-Republic Newspaper
removed_email_address@domain.invalid
509-577-7732
Juan Carlos V. SINE95 (Guest)
on 2006-01-25 21:59
(Received via mailing list)
Hi!
   your problem is due to firewall. You disable firewall windows XP and
programs mask ips like steagnos anonymous, zone alarm, etc. I use
windows xp with distribution ruby 1.8.2 i haven't problems before
uninstall this programs.

JCV
<http://digg.com/security/Anonymous_Browsing_Proxy_...

Greg escribió:
> --include-dependencies
> ERROR:  While executing gem ... (OptionParser::InvalidOption)
>     invalid option: --include-dependencies
>
> Hard to believe.  Did I do something wrong?
>
> Greg
>
>
>


--

*Juan Carlos V. Garrido*

*Sine95***

Gran Vía 43, 2ª plta.

Madrid 28013

Tel.: 91 548 20 90

Fax: 91 548 42 55
www.sine95.com <http://www.sine95.com/>



------------------------------------------------------------------------

Este mensaje se dirige exclusivamente a su destinatario y puede contener
información privilegiada o confidencial. Si no es vd. el destinatario
indicado, queda notificado de que la utilización, divulgación y/o copia
sin autorización está prohibida en virtud de la legislación vigente. Si
ha recibido este mensaje por error, le rogamos que nos lo comunique
inmediatamente por esta misma vía y proceda a su destrucción.



This message is intended exclusively for its addressee and may contain
information that is CONFIDENTIAL and protected by professional
privilege. If you are not the intended recipient you are hereby notified
that any use, copy or disclosure of this communication is strictly
prohibited by law. If this message has been received in error, please
immediately notify us via e-mail and delete it.
Jim McFarland (Guest)
on 2006-01-25 22:05
(Received via mailing list)
I have Ruby from the latest one click installer and ran that same
exact gem command with no problems last week.

later...
jim
Ben M. (Guest)
on 2006-01-25 22:17
(Received via mailing list)
Juan Carlos V. SINE95 wrote:
>>
>>and it doesn't even work:
>>
>>C:\ruby>"C:\ruby\bin\ruby.exe" "C:\ruby\bin\gem" install rails
>>--include-dependencies
>>ERROR:  While executing gem ... (OptionParser::InvalidOption)
>>    invalid option: --include-dependencies

No, I'm pretty sure this is a gem version error... why would a firewall
issue cause an
InvalidOption error in ruby's OptionParser? Plus, I don't have any
firewall software and I
had this error; then I updated rubygems and it went away.

b
Juan Carlos V. SINE95 (Guest)
on 2006-01-25 22:26
(Received via mailing list)
it's true. you are right.

That version is of gem?

&

don't work? |*
    c:\ruby\gem update

*|bye. JCV

Ben M. escribió:
This topic is locked and can not be replied to.