Forum: Ruby on Rails webrick and in_place_editor_field

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Parker T. (Guest)
on 2006-01-24 08:49
(Received via mailing list)
I'm having a strange problem with webrick spinning forever.  I have a
view 'list' that renders a collection:

<%= render :partial => 'item', :collection => @items %>

The item partial looks like so:

<div id="item_<%= item.id %>">
  ...
  <div id="price">
    <%= in_place_editor_field :item, :price %>
  </div>
</div>

If I delete the in_place_editor line the page will render.  If I leave
it there webrick will spin indefinitely, but will never print anything
to the console or to the log.  I'd run lighttpd but am having library
path issues with that I"d prefer not to address right now.  Webrick
*should* work here.

Thanks for any insight you can provide,

pt.
--
Parker T.
http://www.parkert.com/
510.541.0125
Parker T. (Guest)
on 2006-01-24 09:04
(Received via mailing list)
Hmm, I was able to work around this by running webrick in production
mode.

One other caveat, to get in_place_editor_field to work, I had to
modify it to read:

  <%= @item = item; in_place_editor :item, :price %>

Luckily I was able to find an allusion to having to do this in
partials on this list (god bless gmail search).

Thanks,

pt.

On 1/23/06, Parker T. <removed_email_address@domain.invalid> wrote:
>     <%= in_place_editor_field :item, :price %>
>
> pt.
> --
> Parker T.
> http://www.parkert.com/
> 510.541.0125
>


--
Parker T.
http://www.parkert.com/
510.541.0125
Eric G. (Guest)
on 2006-11-08 00:45
Im getting a similar error where the inplace field will be in "saving
mode" indefinately, anybody know how to fix this?
This topic is locked and can not be replied to.