Forum: Ruby on Rails problem when porting

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Antoine Solomon (Guest)
on 2006-01-19 23:08
(Received via mailing list)
Hello,

I am a total beginner when it comes to rails and would like to know are
there any issues with porting rails from freebsd to windows?
This is the error that I have

Bad file descriptor - /tmp/mysql.sock

I am not sure if this would help or not but I am currently on a cygwin
environment

thanks if anyone can help
Will B. (Guest)
on 2006-01-19 23:17
(Received via mailing list)
I'm not sure if socket-based MySQL runs on Windows...  have you tried
changing your database.yml file to point to localhost at port 3600
instead?
Comment out the socket part of the config.

-Will
Antoine Solomon (Guest)
on 2006-01-19 23:29
(Received via mailing list)
i still get the same problem

No such file or directory - /tmp/mysql.sock
Antoine Solomon (Guest)
on 2006-01-20 00:17
(Received via mailing list)
I also downloaded some sameple code from agile web development rails
book
and I still get the same problem.   Has anyone had any issues with
cygwin
and rails?
This topic is locked and can not be replied to.