Forum: Ruby on Rails lighttpd config on os x

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Pat M. (Guest)
on 2006-01-19 16:35
(Received via mailing list)
I finally got around to installing lighttpd on my mac for dev work,
followed the instructions at
http://hivelogic.com/articles/2005/12/01/ruby_rail...

When I go into my rails app and type "./script/server" I get the
following errors:
baggio:~/work/teore pergesu$ ./script/server
=> Booting lighttpd (use 'script/server webrick' to force WEBrick)
=> Rails application started on http://0.0.0.0:3000
=> Call with -d to detach (requires absolute paths in
config/lighttpd.conf)
=> Ctrl-C to shutdown server (see config/lighttpd.conf for options)
2006-01-19 06:52:05: (mod_fastcgi.c.989) execve failed for:
public/dispatch.fcgi No such file or directory
2006-01-19 06:52:05: (mod_fastcgi.c.1015) the fastcgi-backend
public/dispatch.fcgi failed to start:
2006-01-19 06:52:05: (mod_fastcgi.c.1019) child exited with status 2
public/dispatch.fcgi
2006-01-19 06:52:05: (mod_fastcgi.c.1022) if you try do run PHP as
FastCGI backend make sure you use the FastCGI enabled version.
You can find out if it is the right one by executing 'php -v' and it
should display '(cgi-fcgi)' in the output, NOT (cgi) NOR (cli)
For more information check
http://www.lighttpd.net/documentation/fastcgi.html...
2006-01-19 06:52:05: (mod_fastcgi.c.1027) If this is PHP on Gentoo add
fastcgi to the USE flags
2006-01-19 06:52:05: (mod_fastcgi.c.1314) [ERROR]: spawning fcgi failed.
2006-01-19 06:52:05: (server.c.702) Configuration of plugins failed.
Going down.


webrick still runs fine...public/dispatch.fcgi definitely exists, as
does the interpretter specified in the shebang (/usr/local/bin/ruby).
Any clue why this is complaining?

Pat
Ben R. (Guest)
on 2006-01-19 18:39
(Received via mailing list)
I think the problem lies in your lighttpd.conf.  Did rails copy in a
script
the first time you ran it? or did you create it on your own?

~ Ben
Hasan D. (Guest)
on 2006-01-19 18:42
(Received via mailing list)
Pat:
On Jan 19, 2006, at 5:57 AM, Pat M. wrote:

> I finally got around to installing lighttpd on my mac for dev work,
> followed the instructions at
> http://hivelogic.com/articles/2005/12/01/
> ruby_rails_lighttpd_mysql_tiger

I solved the problem you're having by commenting out the FastCGI
lines in lighttpd.conf yesterday.
Cheers,
Hasan D. <removed_email_address@domain.invalid>
Pat M. (Guest)
on 2006-01-20 06:07
(Received via mailing list)
Rails copied it in by itself, I didn't create/touch it.

Pat
This topic is locked and can not be replied to.