Forum: Ruby on Rails (ActiveRecord::AdapterNotSpecified) Error

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Kavika V. (Guest)
on 2006-01-14 19:23
(Received via mailing list)
All,
I am on Mac OS X 10.4, went through all the installation steps for mysql
and ruby on rails. Now, I am getting this error when
trying to start webrick or when trying to create the tables:

/usr/lib/ruby/gems/1.8/gems/activerecord-1.13.2/lib/active_record/
connection_adapters/abstract/connection_specification.rb:73:in
`establish_connection': development database is not
 configured (ActiveRecord::AdapterNotSpecified)


I am using the following database.yml file (passwords replaced with *):

development:
	adapter: mysql
	host: localhost
	database: depot_development
	username: root
	password: ********

test:
	adapter: mysql
	host: localhost
	database: depot_test
	username: root
	password: ****

production:
	adapter: mysql
	host: localhost
	database: depot_production
	username: root
	password: *****

Please help!!!

Thanks
Wilson B. (Guest)
on 2006-01-16 01:03
(Received via mailing list)
On 1/14/06, Kavika V. <removed_email_address@domain.invalid> wrote:
>
>         adapter: mysql
>         password: *****
>
> Please help!!!
>

Double-check your database.yml file against the example one.
Whitespace is significant in YAML files, so make sure you don't have
any trailing spaces, or mixtures of tab characters and spaces, etc,
etc.  Your text editor may be doing some strange replacements on your
behalf.
This topic is locked and can not be replied to.