Forum: Ruby on Rails Rails on OS X Panther vs. libncurses.5.4.dylib

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Chirs Renner (Guest)
on 2005-11-18 06:35
Trying to get Rails working on mac os 10.3.9, webbrick crashes every
time I try to access a dynamic page.  The error message I get is:

"dyld: ruby can't open library: /usr/lib/libncurses.5.4.dylib  (No such
file or directory, errno = 2)"

So, libncurses.5.4.dylib is only there on tiger.  10.3.9 has
libncurses.5.dylib.

Is Rails now Panther-incompatible?  I installed using RubyGems, so maybe
the only available version now is tiger only.  But I would hope to find
some mention of that somewhere.  Nowhere have I found the words "10.4
required" and plenty of sites are still offering (now broken) tutorials
to get rails running on panther.

Any help?  is there something I'm missing, or do I just have to buy
Tiger?
robert (Guest)
on 2005-11-18 09:42
(Received via mailing list)
Rails definitely runs on Panther;  you don't need to upgrade to
Tiger.   I don't know the solution to this problem though.

Robert
alex (Guest)
on 2005-11-18 10:12
(Received via mailing list)
Chirs Renner wrote:
> the only available version now is tiger only.  But I would hope to find
> some mention of that somewhere.  Nowhere have I found the words "10.4
> required" and plenty of sites are still offering (now broken) tutorials
> to get rails running on panther.
>
> Any help?  is there something I'm missing, or do I just have to buy
> Tiger?
>

I'm using Rails daily on Panther.  It doesn't work with the
out-of-the-box ruby, though.  I installed mine from Fink and then
tweaked the $PATH to make it all work, but that was a while ago.
Nowadays it might be better to go with Locomotive, just because it's
quicker to get up and running.

Just to be sure, I just gem updated rails to be sure I had the latest
bits, and a fresh project scaffold works perfectly.
This topic is locked and can not be replied to.