Forum: Ruby on Rails File upload via SSL not possible

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
E.K. (Guest)
on 2006-01-10 15:10
We use an apache server (version 2.0.54) with mod_ssl and the latest
rails version on a Gentoo Linux OS.

We tried to run our application in both, a virtual host using HTTP and
another using HTTPS with identical server configurations. With HTTP, we
did not have any problem, but HTTPS did not allow us to upload files in
rails into a database.

The log file displays a fcgi timeout and the HTTP return status is 500
(server error).

We assume that mod_ssl and fcgi (not fastcgi) do not communicate

Did anyone already have this error? How can it be solved?
Darragh C. (Guest)
on 2006-01-22 19:41
> Did anyone already have this error? How can it be solved?

I just deployed my app against apache2/mod_ssl etc as you mention - and
have the same problem.

the fastcgi.crash.log contains the following

[22/Jan/2006:17:34:36 :: 6019] Dispatcher failed to catch: no content
body (EOFError)
  /usr/lib/ruby/1.8/cgi.rb:978:in `read_multipart'
  /usr/lib/ruby/1.8/cgi.rb:2269:in `initialize'
  (eval):16:in `initialize'
  /usr/lib/ruby/1.8/fcgi.rb:600:in `new'
  /usr/lib/ruby/1.8/fcgi.rb:600:in `each_cgi'
  /usr/lib/ruby/1.8/fcgi.rb:597:in `each'
  /usr/lib/ruby/1.8/fcgi.rb:597:in `each_cgi'
almost killed by this error

I don't have a solution yet
This topic is locked and can not be replied to.